Cannot install docker on ubuntu 22.04.2

Description: Ubuntu 22.04.2 LTS Release: 22.04 Codename: jammy
Docker Version: 23.0.6
When trying to install docker via the official documentation, the installation errors out when trying to install docker-ce package.

Tried to install the package separately and got the same error:

Job for docker.service failed because the control process exited with error code.
See "systemctl status docker.service" and "journalctl -xeu docker.service" for details.
invoke-rc.d: initscript docker, action "start" failed.
● docker.service - Docker Application Container Engine
     Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
     Active: activating (auto-restart) (Result: exit-code) since Tue 2023-05-09 11:03:50 CDT; 5ms ago
TriggeredBy: ● docker.socket
    Process: 19952 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
   Main PID: 19952 (code=exited, status=1/FAILURE)
        CPU: 64ms
dpkg: error processing package docker-ce (--configure):
 installed docker-ce package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:

I had docker installed on this system working perfectly yesterday. Reinstalled to try to solve something, and now cannot install back :confused:

trying to install docker engine on Ubuntu, and expected it to work like before: successfully.

Did you do: apt-get remove docker docker-engine containerd runc prior to reinstalling docker?
Can you give the results of apt-cache policy docker and apt-cache policy docker-ce?

1 Like

Finally found solution: [Solved] Docker service fail to start after update

see post from ‘sahson’.

I followed his instructions and rebooted then it worked.