Docker Community Forums

Share and learn in the Docker community.

Cannot run "numactl --interleave=all" in Docker


(Hoody4032) #1

If I run

numactl --interleave=all

It will give me following errors:

set_mempolicy: Operation not permitted
setting interleave mask: Operation not permitted
I am using a Centos 7 image.

Any idea how to fix it?

Thanks!


(Think) #2

try to run it with --privileged

docker run -ti --privileged centos .....


(Hoody4032) #3

If I use the --privilieged parameter, it gives me another error.

numactl: This system does not support NUMA policy


(Think) #4

did you try it on play-with-docker.com?


(Sdpippin) #5

Docker blocks certain syscalls from happening. Unfortunately mempolicy is one of those

Add the following to your run file:

–security-opt seccomp=/…/seccomp.json \

Here is the custom seccomp file I used - thanks to w1ndy for providing this.