Can't Get Past: Docker for Mac needs privileged access to install its networking components and links to the Docker apps

Is your machine is equipped with Apple M1 chip or Intel chip?

If your machine is an Apple M1, then you need to do more than what need. Please follow recommended link in above message. If it’s intel then read my following comment:

Before you make any changes, try to understand why’s? I typically found 2 common issues.

  1. As I mentioned in solution, /Library/LaunchDaemons/com.docker.vmnetd.plist file is corrupted and needed to copy one form the core application files.
  2. In Bigsur, the file locations were re-arranged. Usually, applications are installed either in /Applications/ or ~/Applications/ If you installed your application in Home and running as root application then obviously it will ask for permissions. But, when your brew update && brew upgrade installs new version in root but using a plist of home one then it conflicts itself and throws this issue.

Now we know, why’s…

Let see what to do,

  1. Uninstall any docker from your machine, either it maybe in /Applications/ or in ~/Applications/
  2. Install docker again
  3. If it still asks the user permissions, then follow my solution above.

Hello bh4r4th, thank you for your help. My machine is equipped with the Intel chip. It’s embarrassing but I realised that it asked for the password of my Mac account, not Docker account and yes it worked finally. Sorry, I was not thinking properly when I opened up Docker Desktop for the first time.

Still, thank you for your help and I appreciate it.

1 Like

This method solves my issue on M1 Mac as well. Thanks!

fixed this by deleting /Library/LaunchDaemons/com.docker.vmnetd.plist

(post deleted by author)

Thanks, This resolved my problem

rm -rf /Library/LaunchDaemons/com.docker.vmnetd.plist

Also fixed my issues after a MacOS time machine backup using the solution from @bh4r4th

Much obliged @bh4r4th, really appreciate you sharing.

Solved my issue too. By the way, the new path to the vmnet has changed to /Applications/, but the file is corrupted :

plutil -convert json  /tmp/com.docker.vmnetd
/tmp/com.docker.vmnetd: Property List error: Unexpected character Ï at line 1 / JSON error: JSON text did not start with array or object and option to allow fragments not set. around line 1, column 0.