Can't Get Past: Docker for Mac needs privileged access to install its networking components and links to the Docker apps

I previously successfully installed Docker for Mac in June 2017. I haven’t used it for a while. When I started it again I got prompted to update it. Now when I launch Docker I get prompted for my password, with the following expected message:

Docker for Mac needs privileged access to install its networking components and links to the Docker apps.

I provide my password, there is a slight delay, then I get prompted again. It looks like some process is blocking the installation. I do have Trend Micro Systems security running, but a colleague does too and says it doesn’t block him.

Anyone else having this problem? Is there a fix? Thx.

I am having this problem, would love to hear if there is a fix. I tried reinstalling Docker but it didn’t help.

I solved the problem by running the docker command from the command line using sudo.

Tried that, but I just get a message saying “Failed to register new version.”

Try booting in safe mode and using sudo.

I am having this problem,too.How to booting in safe mode?

I faced this issue, except I wouldn’t get the prompt for my computer credentials, it would hang with the rainbow-spinner before that moment. Retried a few times.

Resolved by restarting.

For me, my company’s VPN was causing the prompt to hang and not go away. Disconnecting from the VPN allowed me to get passed the prompt and put my password in.

I am not solve the same problem until i restart my mbp (2020, 16inch). amazing.

Received a popup asking to update to (from this morning, now I’m facing this issue. Have been trying for hours to figure it out. Tried everything on this list and within a wide google search radius of it. Uninstalling doesn’t even work.

Running Mac OS Catalina 10.15.6

This happened to me after brew update && brew upgrade and installing macOS Big Sur Version 11.2.1. This did not allow me to start both teamViewer and docker. Re-installation fixed teamViewer but not for docker. When I run docker ps, it pointed that daemon isn’t running and throwing this privileged access popup. Then realised, VirtualBox is used under the hood by docker. When I spin-up VirtualBox it didn’t work either. So, simple and dumb issue is /Application/* aren’t accessible from current user. So, used sudo chmod -755 /Applications/* to change permissions for all applications and now docker is running as expected. Hope this helps.

No need to re-install. Just try changing the permissions first.

I ran into this issue recently.
After upgrading to macOs BigSur, my docker desktop didn’t work.

Went into this looping popup Docker needs privileged access.

I re-installed docker desktop but that did not work.
Then I notice this happening immediately after restart or startup. So, checked services by running command launchctl list | grep docker

Then I did this:

  • rm -rf /Library/LaunchDaemons/com.docker.vmnetd.plist

  • sudo cp /Applications/ /Library/LaunchDaemons/com.docker.vmnetd.plist

  • sudo launchctl load -Fw /Library/LaunchDaemons/com.docker.vmnetd.plist

  • launchctl list | grep docker

Then restart from Dock or finder. All green for me.


genius! problem solved running the commands. :grinning:

1 Like

thanks! It`s solved my problem

1 Like

what a great job ~ thank you very much

1 Like

I have the same issue on Apple M1, tried the commands but it still doesn’t work …
Anyone knows how to fix this ?

Hi @lyabie,
I have tested this on Mac with intel chip (not the new M1). Not sure how different the OS and file system is designed. To my guess, it should be same linux overlay as old macs. I recommend to closely examine where the .plist files are getting stored when you install applications from appStore and also applications using brew.

As I do not have a M1 machine with me at the moment, I won’t be able to help you with the issue.

After encountering this error upon migrating to a computer with BigSur, the following from @ bh4r4th was all I needed to do:

Afterwards, I got asked just once for privileged access. My guess is that that plist is now obsolete, but if it exists, it causes problems.


Hello bh4r4th,

I am new to Docker and I had encountered the same message as you. Tried to open Docker Desktop on my BigSur Mac and entered my password but the same popup still appeared. I tried following your command lines until * sudo cp /Applications/ /Library/LaunchDaemons/com.docker.vmnetd.plist. It prompted for the password so I entered the password that I use for my Docker online account but the password did not work.

What should I do in order to install the Helper tool and also open Docker Desktop?

Thank you.

I recently got a hand over the Apple M1 Laptop which I setup for one of our new Devs. I noticed that the file system and paths are different on M1.

I highly recommend using this link to setup any other softwares. Also, worth installing docker via homebrew instead.

Note: Do not miss to setup iterm terminal for rosetta. If not, you will endup running arch -arm64 as prefix to all the commands.