Docker Community Forums

Share and learn in the Docker community.

Can't load a docker image in windows server 2016


(Sbrauer) #1

I’m trying to load an image on my Windows Server 2016. But for some reason I’m unable to do so. I have tried several things. Including:

Saving an image, copy pasting it to the server and trying to load it (docker load…). This gives the error you see down below. I also tried to load the image through docker hub. But using docker pull gives me the exact same error.

I’ve tried pulling other images like microsoft/windowsservercore which was successful. On my development machine and server I’m using windows containers. The windows server runs in a virtual machine.

I’ve created a sample project on https://hub.docker.com/r/sbrauer/dockert/. This project is just a asp.netcore web api project with the default ‘valuescontroller’ as a test. But this gave me the same error.

I have to say that pulling the image to my dev machine (w10) works perfectly fine. I tried to load the image on the server using docker CE and using docker EE but both to no avail.

error code:

failed to register layer: re-exec error: exit status 1: output:
ProcessUtilityVMImage C:\ProgramData\Docker\windowsfilte
r\13f0d09f57da5375955d3563b3a199fd1f3563365abe5b31640eee885aac448a\UtilityVM:
The system cannot find the path specified.

Thanks for any help in advance. I also made a stackoverflow question for those interested: