Docker Community Forums

Share and learn in the Docker community.

Centos7 and docker 1.8.2 start daemon question


(Rparen) #1

I am trying to start docker on centos7.1 using the instructions from https://docs.docker.com/installation/centos/. After installing, whenever I try to start the daemon (sudo service docker start) with docker versions 1.8.0-1.8.2 (the latest version), it doesn’t start properly, and I get this error when looking into systemctl:

time=“2015-10-05T13:54:52.110265341-05:00” level=info msg="[graphdriver] using prior storage driver “devicemapper”"
time=“2015-10-05T13:54:52.111327209-05:00” level=info msg="Option DefaultDriver: bridge"
time=“2015-10-05T13:54:52.111360582-05:00” level=info msg=“Option DefaultNetwork: bridge"
2015-10-05T13:54:52.118300330-05:00” level=warning msg="Running modprobe bridge nf_nat br_netfilter failed with message: modprobe: WARNING: Module br_netfilter not found.\n, error: exit status 1"
systemd[1]: docker.service operation timed out. Terminating.
systemd[1]: Failed to start Docker Application Container Engine.
systemd[1]: Unit docker.service entered failed state.

When I grabbed an older version of docker (1.7.1) it installed and started with no problems. Is there something I’m missing when trying to install the most recent docker engine to centos7.1? Or is there a compatibility issue that anyone has seen?

My kernel: 3.10.0-229.el7.x86_64
My Os: CentOS Linux release 7.1.1503 (Core)

Thanks.


(Declanmc) #2

Disabling firewalld fixes this problem


(Rparen) #3

Is there a reason I would need to disable firewall in this case but not for the previous version? Basically why is it necessary here.


(Ranjandas) #4

Hi,

This issue is detailed in this github issue https://github.com/docker/docker/issues/15498. Its the selinux policy that is getting in the way between docker and firewalld. Installing docker-selinux package will get this working without disabling firewalld.

Just documented it my blog here http://blog.ranjandas.me/install-docker-1-8-x-on-centos-7/ :smile: .

Regards


(Duel007) #5

Hi @ranjandas, I’m having the same issue, but installing the selinux package does not change anything. I’m trying on a fresh install of the latest Centos7 release and everything, not sure where my problem is.