Change registry where docker images are installed to in linux

I have two servers - server A and server B. Server A acts as a Kubernetes deployment server and I am running a program on it that performs a docker pull to download an image from Server B (which is a server that acts as a cluster node). Let’s say the image server A is trying to pull is from /usr/bin/docker

But the docker pull keeps failing with the error “Error response from daemon: received unexpected HTTP status: 504 Gateway Timeout”. This is because the registry it’s trying to pull from doesn’t exist on server B.

In server B, when I use the command “docker images” what is actually displayed is something in the format:

As you can see, the ending of the registry is the same: “/some/thing” but the rest of it before that is different.

Is it possible to change the registry that the image actually exists on in server B to what docker is trying to pull from? The program is pulling from the registry that the image should actually be located in, but for some reason my server keeps downloading docker images to the artifactory repo.

I tried physically changing the registry name in server B’s repositories.json file as well as changing the repository name displayed from “docker images” using the docker image tag command, but I am still getting the same error when I attempt to perform a docker pull.