Docker Community Forums

Share and learn in the Docker community.

Client version 1.18 is too old. Minimum supported API version is 1.24,

ci

(P4vv37) #1

Hi!

I am very new to docker, but I’m trying to use a gitlab docker runner ( gitlab-runner-windows-amd64.exe ) to run my tests. I need docker to run windows.

I’m getting an error:

ERROR: Job failed (system failure): Error response from daemon: client version 1.18 is too old. Minimum supported API version is 1.24, please upgrade your client to a newer version (executor_docker.go:1161:0s)

I’ve found several posts on the web, but none of them helped me:

*mehraban.com.au/2017/02/15/are-you-facing-docker-version-error/ - it is set to 3 in my docker-compose.yaml

  • lik

My hist os is Windows 10
I’m using a dockerfile:
Python 2.7.15, windows: 2.7.15-windowsservercore-ltsc2016

My docker-compose.yaml:
version: ‘2.1’

services:
  my_new_python_27:
    image: user/my_new_python_27
    build: .

docker version:

Client:
 Version:           18.06.1-ce
 API version:       1.38
 Go version:        go1.10.3
 Git commit:        e68fc7a
 Built:             Tue Aug 21 17:21:34 2018
 OS/Arch:           windows/amd64
 Experimental:      false

Server:
 Engine:
  Version:          18.06.1-ce
  API version:      1.38 (minimum version 1.24)
  Go version:       go1.10.3
  Git commit:       e68fc7a
  Built:            Tue Aug 21 17:36:40 2018
  OS/Arch:          windows/amd64
  Experimental:     false

docker-compose version:

docker-compose version 1.22.0, build f46880fe
docker-py version: 3.4.1
CPython version: 3.6.6
OpenSSL version: OpenSSL 1.0.2o  27 Mar 2018

Where am I making a mistake?

Regards


(P4vv37) #2

Ping?
I still cannot make it work