Docker Community Forums

Share and learn in the Docker community.

"Cloudstor" volume plugin missing


(Deep Debroy) #21

Hi @assurehedgedoc which channel in 17.06 did you try? edge and stable should have cloudstor pre-installed. Did you use test by any chance?

Please note that the installation commandline for Azure is:

docker plugin install --alias cloudstor:azure --grant-all-permissions docker4x/cloudstor:17.06.0-ce-azure1 CLOUD_PLATFORM=AZURE AZURE_STORAGE_ACCOUNT_KEY="$SA_KEY" AZURE_STORAGE_ACCOUNT="$SA" DEBUG=1

where $SA is a storage account (either one of the five created by the Docker4Azure ARM template or any other Storage Account that you create/manage independently) and $SA_KEY is the access key for the storage account.


(Assurehedgedoc) #22

I tried on both stable and edge to no avail. No I didn’t use test. I tried the manual string mentioned but I get the same error.

The plugin comes but when I docker plugin ls but it won’t enable.
2cb138c3be5c cloudstor:azure cloud storage plugin for Docker false

Has it anything to do with my regions? West/North Europe?


(Agilyslaurent) #23

Hello,

I tried to create a new swarm on azure using docker cloud in swarm mode today (stable channel).

As @assurehedgedoc says, the version 17.06 is deployed but cloudstor is not installed.

I also deployed on West Europe.

Maybe this is linked to Docker Swarm Mode rather than Docker for Azure? If that is the case, let me know and I will create a topic over there.

Regards,

Laurent


(Agilyslaurent) #24

To provide more information :

Running the command @ddebroy provided to manually install cloudstore worked properly. However, it is not practical as it needs to be installed on all workers and will need to be installed on new machines when scaling up the VM scaling set.


(Deep Debroy) #25

@agilyslaurent @assurehedgedoc Can you please execute:
grep cloudstor /var/log/docker.log

on one of the nodes where Cloudstor is in the disabled state and see if there are any errors?

I just tried the West Europe region and found Cloudstor installed there fine.

@agilyslaurent you can issue the command with a utility we have called swarm-exec in Docker4Azure nodes and that will make sure the command is executed in all nodes of the swarm as well as any new nodes that come up. However I would like to get some info on any errors that pop up in the /var/log/docker.log regarding Cloudstor installation issues.


(Agilyslaurent) #26

@ddebroy
I just executed the command grep cloudstor /var/log/docker.log and it returns nothing.
To clarify, cloudstor is not in the disabled state : it is not installed at all (docker plugin ls returns no rows).

Also, we are creating the swarm via docker cloud swarm mode, not in the azure market place. Like I said earlier, maybe it is a problem with Docker Cloud rather than the Azure for Docker image?

Thank you for pointing out the swarm-exec. We will try it on our swarm.


(Assurehedgedoc) #27

Grep returns nothing. Even on the swarm with the disabled cloudstor.

I created a new swarm this morning, cloudstor wasn’t installed but manually installing worked.


(Deep Debroy) #28

@agilyslaurent Thanks for clarifying the bit about the fact that you are initializing through Docker Cloud. Cloudstor won’t get installed for swarms created by Docker Cloud by default at the moment. You will need to install cloudstor separately through swarm-exec and passing it the docker plugin install .. command line. We will address this shortly.

I had confused your message with the report about Cloudstor showing up disabled from @assurehedgedoc.


(Deep Debroy) #29

@assurehedgedoc How about if you grep with the plugin ID after dropping into the host OS environment?

  1. Drop into the host OS environment with docker run -it --privileged --pid=host justincormack/nsenter1
  2. Grep on all logs (in case latest docker logs got archived): grep $(docker plugin ls | grep cloudstor | cut -d' ' -f1) /var/log/*

(Twginfrastructure) #30

@ddebroy I have the same issue - not going through cloud.docker.com, but installing this via the https://docs.docker.com/docker-for-azure/ page

plugin shows disabled. I tied to install this manually via the command you suggested, I still get
Error response from daemon: dial unix /run/docker/plugins/b3e20d266064e51bff1585454ab254fdbcad57b39631195e3ec4732e2d38a9de/cloudstor.sock: connect: no such file or directory

logs:
Jul 17 03:24:32 moby root: time=“2017-07-17T03:24:32.609678200Z” level=debug msg="Trying to pull docker4x/cloudstor from https://registry-1.docker.io v2"
Jul 17 03:24:35 moby root: time=“2017-07-17T03:24:35.224390700Z” level=debug msg="Pulling ref from V2 registry: docker4x/cloudstor:17.06.0-ce-azure1"
Jul 17 03:24:37 moby root: time=“2017-07-17T03:24:37.570243900Z” level=debug msg="Calling POST /v1.30/plugins/cloudstor:azure/set"
Jul 17 03:24:37 moby root: time=“2017-07-17T03:24:37.600925700Z” level=debug msg="Calling POST /v1.30/plugins/cloudstor:azure/enable?timeout=0"
Jul 17 03:24:50 moby root: time=“2017-07-17T03:24:50.224349400Z” level=debug msg="error net dialing plugin: dial unix /run/docker/plugins/b3e20d266064e51bff1585454ab254fdbcad57b39631195e3ec4732e2d38a9de/cloudstor.sock: connect: no such file or directory"
Jul 17 03:24:50 moby root: time=“2017-07-17T03:24:50.551648400Z” level=debug msg=“error net dialing plugin: dial unix /run/docker/plugins/b3e20d266064e51bff1585454ab254fdbcad57b39631195e3ec4732e2d38a9de/cloudstor.sock: connect: no such file or directory”


(Andrewroth) #31

Any update on this? Deploying a swarm using Docker Cloud still does not include Cloudstor.


(Sebastianbk) #32

I am having the same issue as @andrewroth. I am not seeing the Cloudstor plugin on a newly deployed Docker Swarm (deployed via Docker Cloud using Microsoft Azure as service provider).

@ddebroy, could you provide some information on this issue?


(Paranoidrat) #33

I tried to install cloudstor on Docker Swarm 17.12.0-ce manually deployed in Azure using the followign

sudo docker plugin install --alias cloudstor:azure --grant-all-permissions docker4x/cloudstor:17.12.0-ce-azure1 CLOUD_PLATFORM=AZURE AZURE_STORAGE_ACCOUNT_KEY="****" AZURE_STORAGE_ACCOUNT="****" DEBUG=1

Got the same error

Error response from daemon: dial unix /run/docker/plugins/3e5a75a71dc44d6dc93a8e4551434d5938147df069f763fd6761e12c69974ef4/cloudstor.sock: connect: no such file or directory

Is it related to the hosts configuration in daemon.json? Or maybe socket has to be exposed to the cloudstor container somehow?


(Adijes) #34

hi @ddebroy,
I did the steps mentioned here to install the plugin:

docker plugin install --alias cloudstor:azure --grant-all-permissions docker4x/cloudstor:azure-v17.03.0-ce CLOUD_PLATFORM=AZURE AZURE_STORAGE_ACCOUNT_KEY="***" AZURE_STORAGE_ACCOUNT="***"

It works, but! when i have 2 service containers running on the same node that uses the same mount, i am getting an error

starting container failed: error while mounting volume '/var/lib/docker/plugins/1165f4763631bcbebedf59d107f99b9013dc2c210db388172c8815fa61eacba3/rootfs': VolumeDriver.Mount: mount failed: exit status 32
output="mount error(16): Resource busy\nRefer to the mount.cifs(8) manual page (e.g. man mount.cifs)\nmount: mounting //hashspotprodmachinesdata.file.core.windows.net/6518c5505abe4a487674c76b823804da on /mnt/cloudstor/applogs failed: Resource busy\n""

that the cloudstor supports such situation when 2 containers running on the same node with same mapping?
(again - if i will have 2 nodes each running one container using cloudstor it will work,
but if i will have 2 nodes and one of them tries to run to containers with same cloudstor mapping - it will fail).


(Rquackenbush) #35

I’m still having the same issue with version ‘docker4x/cloudstor:18.06.0-ce-azure1’ of the plugin:

Error response from daemon: dial unix /run/docker/plugins/b523465c05712da9213a8713ac41067be2365d425b77f68a442486fde2284ad9/cloudstor.sock: connect: no such file or directory

Any updates?


(Harcher81) #36

I had the same issue and I found that don’t work when the option force https is enabled on the Storage Account.