Configured "insecure-registry" property in daemon.json in Docker Desktop Settings, now my DockerHub account is broken

My DockerHub broke after I introduced the “insecure-registry” property into the Docker Desktop > Settings > Docker Engine > daemon.json config. The Hub cannot load pages when I’m logged out, and it is constantly restarting pages when I’m logged in. I have since removed the property, applied the change, and restarted Docker Desktop, but Hub hasn’t been fixed.
I also applied Clean/Purge data, factory reset, uninstall/ reinstall Docker Desktop, and restarted my Mac. No difference on Docker Hub. I also cannot log a Support ticket or contact Support since my account has gone into constant restart mode.
I noticed on Docker’s docs that there’s no information on how to push to an insecure (HTTP) registry. I was following a tutorial on how to push a Docker image to an insecure Nexus repository, which worked, but now my Docker account seems broken.
I’m wondering if there’s a fix available, or if anyone knows how to get in touch with Docker Support? Since my account is broken, I can’t submit a new case. I have tried to join the Docker Community Slack, and that too fails since my account is broken.

Didn’t you find this?

There is a search box in the top right corner. Searching for “insecure” or “insecure registry” gives multiple results. On that page searching for “insecure” again, you can find the config file reference:

and this:

"insecure-registries": [],

but I have to agree that it’s not obvious to people without examples not to mention that the daemon json is not where it would be in case of Docker Engine on Linux.

Your Docker Hub? Don’t you mean your Docker Desktop? You can’t break Docker Hub (hopefully).

If docker pull commands don’t work, your config file is probably syntactically incorrect and you need to fix it. Cany ou share the content of that file?

Do you mean you can’t even log in to Docker Hub here?

If anything happened to your actual Docker Hub account, it is probably not related to your insecure registry issue, but you can write here too:

You don’t need a Docker Hub account for Slack

It is ion the docker support page:

Note: The docker slack link was broken recently, but it seems it is fixed now.

Huge thanks @rimelek for the detailed reply and links, very useful.

Apologies for the delay in my response, as I was unable to replicate this issue the day after but had done nothing to fix it myself. Now I have reproduced it.

I actually meant the Hub. Docker Desktop is functioning fine. I log into the Hub, click Repositories in the header, and the page keeps refreshing from there with this URL: Docker.

Config.json contents:
“auths”: {
“”: {},”: {}
“credsStore”: “desktop”,
“currentContext”: “desktop-linux”,
“plugins”: {
“-x-cli-hints”: {
“enabled”: “true”

The contact link you shared shows “Something went wrong!” with the crying whale.

Docker Community Slack worked now, thanks for stating it was broken recently, since now I understand I didn’t cause my issue there from anything I did. I kept trying to get into that Slack workspace, but was redirected to another workspace.

I think I was able to replicate the issue b/c my browser saved a URL with the code parameter. Every time Docker reloads the Hub Repositories page, it provides a different code value. I just restarted my Mac, and went to (no code param) and it’s working fine.