Connection error inside docker machine

Hello everybody,

I am a new docker user and currently i am trying to follow dockers ‘get started’ tutorials.
At the moment i am trying to build my own image following this tutorial. When i build my own image using the Dockerfile i get this error:

 Cannot initiate the connection to etc.

This happens when the Dockerfile tries to run the:

RUN apt-get -y update && apt-get install -y fortunes

I have installed docker using docker toolbox because i am using windows 7. At the moment i am using docker under a corporate network. I have set HTTP_PROXY and HTTPS_PROXY values as environment variables and i am able to run the hello-world app by executing:

docker run hello-world

The problem is that the virtual machine does not have access to the internet and it can not perform apt-get update and install. When i connect to the machine by executing docker-machine ssh default and try to ping google location i have 100% packet loss.

Also i tried to set HTTP_PROXY values inside the /var/lib/boot2docker/profile file but the problem has not been solved.

So i am assuming it is a connection problem relating to the proxy. Any idea how could i solve this problem?