Container loses volume mount on Mac


since the recent update to the edge version 17.05.0-ce-mac11 (17656) on my mac (Sierra 10.12.5 (16F73)) I am encountering an issue where my container loses volume mounts. I have also tried the most recent stable version 17.06.0-ce-mac18 (18433) without luck.

As advised, I have searched the forum and issue tracker and found a recent issues #1727 and an older forum entry (Container loses volume mount), but they do not seem to match my case or are related to an outdated docker version, so I am opening a new one.

What I am trying to do is to mount two different local directories to my node container. The first is the root directory where all the sources live and the second should be mounted as a sub directory. The “docker-compose.yml” lines look like this:


The expected behavior is that I get all files in the “my-project” directory and on top the files of my common library into the sub directory “node_modules/my-project-common”.

When I run my container with “docker-compose up” and show the mounts of the running container with

docker-compose exec my-container mount | grep osxfs

I actually do get the two mounts as expected with

osxfs on /opt/my-project type fuse.osxfs (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,max_read=1048576)
osxfs on /opt/my-project/node_modules/my-project-common type fuse.osxfs (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,max_read=1048576)

But as soon as something changes in the project directory (e.g. when I compile the sources), I am losing the second mount and the list now only shows the first:

osxfs on /opt/smart-api type fuse.osxfs (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,max_read=1048576)

I am not sure what do do. Let me know what else information I can provide.


This forum is not an official product support or issue reporting channel.

I have finally found what seems to have been the problem. My Mac was still using the “aufs” storage driver. With the “overlay2” storage driver, I am not seeing this issue.