Container name already in use

i open DockerDesktop and see NO containers, just my image, no volumes

to be sure i type

docker ps -a
and there are no containers !!

but i get this error…

docker-compose up
Error response from daemon: Conflict. The container name “/myproject” is already in use by container “660ce781dfce7e878a175c2cabe6e2bbd131fd022fca0df85b49f464aa8bd880”. You have to remove (or rename) that container to be able to reuse that name.

if i do

docker-compose down
docker ps -a
there are NO containers


docker-compose up
gives same ERROR (different container number)

please advise

anyone? i’ve uninstalled docker desktop, deleted all files and folders relating to docker, rebooted, reinstalled… and still i get this ERROR. i’ve tried every suggestion i can find online, but it still wont work.

Solved it.
In the docker-compose.yml file, i had more than one service, and had not renamed the second “container_name”.
But its good to know the error messages are detailed and explanatory, and that theres a vibrant online community full of people willing to help…