Docker Community Forums

Share and learn in the Docker community.

Container rescheduling not working


(Anvesh9) #1

I tried testing the container rescheduling feature but its not working for me. I am doing in through the docker toolbox.
The containers on the killed host could not be found in the cluster. They are killed as well.
I could not find deatiled documentation on rescheduling.
Kindly help regarding the same!!

Thanks in advance!


(Luckyabhishek) #2

I am facing the same issue. Any luck on sorting it out ?
I tried to start my docker-machines with --swarm-experimental flag and the containers with “com.docker.swarm.reschedule-policies=[‘on-node-failure’]” labels
The container started on node-01 . I stopped the node-01. At first docker CLI took quite some time to show that container is no longer there. i.e. It was showing up as a live container, even though the node was dead.
After the container disappeared, it never reappeared on any other node.
Any idea on what could be going wrong ?


(Dvohra) #3

How is rescheduling being set? Is the following referred?