Docker Community Forums

Share and learn in the Docker community.

Daemon configuration Debian

docker

(Benjamindonze) #1

Hello,

I recently installed docker engine on a Debian Jessie. I’m not a linux nor docker expert but I couldn’t manage to configure docker daemon. I did the install as stated in the documentation using apt-get.

I tried putting configuration in /etc/default/docker setting a line with DOCKER_OPTS="…" but even after a restart with “service docker restart” it doesn’t seems to take into account my configs.

Has anyone an idea?
Thank you for your help.


(Ranjandas) #2

Hi,

Whats the configuration changes you have made to /etc/default/docker? Also after restarting docker is the service coming up?

Regards


(Benjamindonze) #3

I set up secured https on daemon. So --tlsverify… -H tcp://…

Yes it does restart well. Yes I’m sure my options are ignored I can’t connect with clients on the port opened. I can see the command used with ps and my options are not there.


(Ranjandas) #4

Hi,

This is because Debian is using Systemd and it by default doesnt respect /etc/default/docker file. So for you to get this work you will have to create a systemd dropin file and make the changes in that new file.

Please go through this article for more details. Please let me know if you still need any help.

https://docs.docker.com/articles/systemd/

Regards


(Benjamindonze) #5

Yes I finally found out. Very sad that this file is created on Debian but not used and more important that the documentation on Debian install doesn’t point to that page.


(Erixun) #6

@ranjandas I know this is an old post, that link is dead to systemd issues. I have just tried to install on a brand new Jessie facing the same problems.
Any guidance appreciated