Docker Community Forums

Share and learn in the Docker community.

Diagnose docker.service startup error?


(Davidmichaelkarr) #1

I’m looking at the book “Puppet for Containerization”, which uses Docker (obviously). As part of the puppet provisioning, docker was installed, and it tried to start the service, but startup failed. I saw the following error first:

==> node-01: Error: /Stage[main]/Docker::Service/Service[docker]/ensure: change from stopped to running failed: Could not start Service[docker]: Execution of '/bin/systemctl start docker' returned 1: Job for docker.service failed because the control process exited with error code. See "systemctl status docker.service" and "journalctl -xe" for details.

After I got onto the box with “vagrant ssh”, I ran “systemctl status docker.service”, and saw the following:

● docker.service - Docker Application Container Engine Loaded: loaded (/usr/lib/systemd/system/docker.service; disabled; vendor preset: disabled) Drop-In: /etc/systemd/system/docker.service.d └─service-overrides.conf Active: failed (Result: exit-code) since Thu 2016-06-16 22:45:34 UTC; 33s ago Docs: https://docs.docker.com Process: 4438 ExecStart=/usr/bin/docker -d -H fd:// $OPTIONS $DOCKER_STORAGE_OPTIONS $DOCKER_NETWORK_OPTIONS $BLOCK_REGISTRY $INSECURE_REGISTRY (code=exited, status=125) Main PID: 4438 (code=exited, status=125)

I also ran “journalctl -xe”, but that found nothing.

What else do I need to see to determine what went wrong here?