Docker Community Forums

Share and learn in the Docker community.

Disable Docker IP masquerade

Hello,
I’ve been familiarizing myself with docker lately and got a rootless git container running on CentOS 8. Sadly I’ve hit a road block.
Fail2ban is running on the host, and I’d like to use it to moderate git logins. Currently, Docker is masquerading all incoming connections though.
Masquerade is disabled in the Docker bridge network aswell as the daemon.json, yet connections still get logged with the bridge ip. I would appreciate if you could point me in the right direction.

Thanks in advance!

Edit:

Issue type
Question

OS Version/build
CentOs 8

App version
19.03.5

Steps to reproduce
Create Network with

driver: bridge
driver_opts: com.docker.network.bridge.enable_ip_masquerade: ‘false’

daemon.json

{
“ip-masq”: false
}

Incoming connection ip’s are masked.

I think this is also a dup of [docker/libnetwork#570] and the fix is ready.