Docker Community Forums

Share and learn in the Docker community.

Disabling ipatbles inside a container failed


(Gpj5552) #1

I get following error when I try to stop iptables:

[root@container1 /]# service iptables stop
iptables: Setting chains to policy ACCEPT: nat filter [ OK ]
iptables: Flushing firewall rules: [ OK ]
iptables: Unloading modules: iptable_nat [FAILED]

It succeeds when I set --iptables=false, but then I the containers are not able to talk to outside world.
Note: I am running docker container inside a vm.

Any help is appreciated.