Docker Community Forums

Share and learn in the Docker community.

Docker apk package for alpine linux has an unresolved dependency to libseccomp


(Guido Zockoll) #1

Since yesterday my builds with the apk package are failing.

Sending build context to Docker daemon 2.048 kB
Step 1 : FROM alpine:3.3
 ---> d7a513a663c1
Step 2 : RUN apk add --update  --repository http://dl-6.alpinelinux.org/alpine/edge/community docker && rm -rf /var/cache/apk/*
 ---> Running in ca88c76c6a2c
fetch http://dl-6.alpinelinux.org/alpine/edge/community/x86_64/APKINDEX.tar.gz
fetch http://dl-cdn.alpinelinux.org/alpine/v3.3/main/x86_64/APKINDEX.tar.gz
fetch http://dl-cdn.alpinelinux.org/alpine/v3.3/community/x86_64/APKINDEX.tar.gz
ERROR: unsatisfiable constraints:
  so:libseccomp.so.2 (missing):
    required by:
                 docker-1.11.0-r1[so:libseccomp.so.2]
The command '/bin/sh -c apk add --update  --repository http://dl-6.alpinelinux.org/alpine/edge/community docker && rm -rf /var/cache/apk/*' returned a non-zero code: 2

(Jeff Anderson) #2

It looks like you are essentially mixing the edge community repository with the 3.3 main repository. 3.3 doesn’t have the libseccomp package, so it fails.

I can’t say that I’m experienced enough with alpine to give you terribly qualified best practices advice, but it seems like it would be ideal to run alpine edge instead of 3.3 if you want edge packages.

other than that, I was able to get the edge docker version installed on alpive 3.3 by doing the following:

$ apk --no-cache add --repository http://dl-cdn.alpinelinux.org/alpine/edge/main libseccomp
$ apk --no-cache add --repository http://dl-cdn.alpinelinux.org/alpine/edge/community docker

(Jeff Anderson) #3

or in one command:

$ apk add --no-cache  --repository http://dl-cdn.alpinelinux.org/alpine/edge/main --repository  http://dl-cdn.alpinelinux.org/alpine/edge/community  docker

(Guido Zockoll) #4

That worked like a charm. As you can see i am also not very experienced using alpine. But this took me a step further.

Many thanks,

Guido