Docker bridge networking does not work in Ubuntu 22.04

Host networking works:

    $ docker run -it --network=host busybox ping
    PING ( 56 data bytes
    64 bytes from seq=0 ttl=58 time=86.721 ms
    64 bytes from seq=1 ttl=58 time=86.572 ms
    64 bytes from seq=2 ttl=58 time=86.631 ms

But bridge networking does not work:

    $ docker run -it --network=bridge busybox ping
    ping: bad address ''

This is the latest Docker version 24.0.2 installed using: “curl | sh”
This is a cloud server from IONOS (1 and 1) that I can re-image. It is running Ubuntu 22.04.2 LTS
The Linux kernel version is: 5.15.0-73-generic

I have already tried re-imaging Ubuntu 22.04.2 and re-installing Docker, but that did not help.

I have tried adding /etc/docker/daemon.json

        "dns": ["", "", ""],
        "debug": true,
        "default-address-pools": [{"base":"","size":24}]

I have edited and rebooted /usr/lib/systemd/network/


    $ brctl show
    bridge name     bridge id               STP enabled     interfaces
    docker0         8000.02424eafcdbb       no

    $ docker network inspect bridge
        "Name": "bridge",
        "Id": "2fe2b9b8da6ec5ceea3b7b6ccd3bb513d3e72b181cb1fc1d784d769b1279637e",
        "Created": "2023-06-04T17:01:21.576943695Z",
        "Scope": "local",
        "Driver": "bridge",
        "EnableIPv6": false,
        "IPAM": {
            "Driver": "default",
            "Options": null,
            "Config": [
                    "Subnet": "",
                    "Gateway": ""
        "Internal": false,
        "Attachable": false,
        "Ingress": false,
        "ConfigFrom": {
            "Network": ""
        "ConfigOnly": false,
        "Containers": {
            "2b176dfcfac36986b642150fa445c172b21f945cc96051e3921ee28b4dc84bd7": {
                "Name": "beautiful_wescoff",
                "EndpointID": "56f288769b0be1f723fd25a3b11469c60552d6fe282b3e6d7ae7a3031a4fb81b",
                "MacAddress": "02:42:0a:0b:00:02",
                "IPv4Address": "",
                "IPv6Address": ""
        "Options": {
            "": "true",
            "": "true",
            "": "true",
            "": "",
            "": "docker0",
            "": "1500"
        "Labels": {}
1 Like

I have the exact same problem with a (IONOS) Linux VPS Contract.

Hi, I also have the same problem with an IONOS vps server, the host network is working fine, the bridge is not working. I tried to contact the Italy customer service they opened a ticket for me with a server operator, in my opinion not at all competent he didn’t even know what docker was, according to her it was not included in my subscription and the solution is to switch to a cloud server, but I see the problem there too. In my opinion it’s the firewall blocking something, also because from the vps I don’t know how to change the rules other than using their panel.

After several hours of discussion with IONOS, they found the problem on global ubuntu configuration, this problem is probably solved, if not please contact IONOS support

Hi, do I have to reinstall the vps or should it work without doing anything? I contacted the assistant the problem is finding a competent operator, the one I spoke to didn’t even know what docker was

I have a solution for you, the problem is netplan, ubuntu 22.04 use netplan to adress ip via DHCP. You need to modify the file /etc/netplan/50-cloud-init.yaml and add en in front of the * :

            dhcp4: true
            dhcp6: true
                name: 'en*'
    renderer: networkd
    version: 2

this will force netplan to use DHCP only on interface en* and the docker interface is docker0

next apply the configuration and restart network:

netplan apply
sudo systemctl restart systemd-networkd

#Docker need to be restarted to request a new ip
systemctl restart docker

Wow It works! Thank you very much, you were very kind. Thank you.

Thank you. It also fixed my problem. With all of the things I originally tried to get it working, I wanted to start from a clean install of 22.04, then I installed Docker, then made the suggested fix, and it works great. Thanks again

Thank you! Ionos support worth less than zero, you saved us.

Solution also worked for me. Thanks.

You saved me after 3 days and night troubleshooting this issue. Thank you very much. <3

OMG! It took me 4 nights to find the cause of this issue but without any result. I almost had to reinstall the OS until I found your solution. Thank you very much =]]]