Docker Community Forums

Share and learn in the Docker community.

Docker build unexpected EOF


(Bliq00) #1

[vagrant@localhost ~]$ docker --version
Docker version 1.8.3, build f4bf5c7

using centos71 Virtualbox

My simple Dockerfile:

FROM centos
RUN yum -y update && yum -y install wget

When I run docker build -t custom/base ., the RUN seems to finish but I end up with a line like this:

Installed:
wget.x86_64 0:1.14-10.el7_0.1

Complete!
—> ec668dd7ef05
unexpected EOF
[vagrant@localhost ~]$

Do I need more in my Dockerfile? Every tutorial seems to have a similar Dockerfile and they seem to expect that it works fine but even when I copy and paste their Dockerfiles, I get this error message after the first RUN statement.

If I run docker build -t custom/base . again, it goes to the next RUN directive and then I get an “unexpected EOF” again, before the next RUN directive.


(Ranjandas) #2

Hi,

Which editor did you use to create the Dockerfile? Can you create a new file with same content(type it and dont copy/paste) and test?

Regards


(Bliq00) #3

I used vi to create the Dockerfile. I copy/pasted the contents of that file to this comment. I’ve tried tearing down the VM and several permutations of the Dockerfile, each time getting hung up on that EOF