Docker Community Forums

Share and learn in the Docker community.

Docker cannot access internet at all


(Phbcanada) #1

I’ve recently re-installed current docker for mac on macos (10.11.4 El Capitan) and all network access from docker seem to be failing. I get an error when attempting to check for updates “An error occrred in retrieving update information”, diagnose and feedback “Failure: Could not upload diagnostic data to remote server (docker-diagnose exit code is 1)” and when trying to pull images “Error response from daemon: Get https://registry-1.docker.io/v2/: Service Unavailable”.

If I run the diagnose only I get all “OK”.

I tried installing docker toolbox and re-installing docker for mac but the same problem continues. I’m assuming at this point some type of network configuration problem but can’t understand why this is happening. My local subnet is running at 192.168.1.0 and it connects to the internet via a gateway router on 192.168.0.0. I don’t have any other local networking problems.

Suggestions are welcome.

docker info

 Running: 0
 Paused: 0
 Stopped: 0
Images: 0
Server Version: 17.12.0-ce
Storage Driver: aufs
 Root Dir: /var/lib/docker/aufs
 Backing Filesystem: extfs
 Dirs: 0
 Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
 Volume: local
 Network: bridge host ipvlan macvlan null overlay
 Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 89623f28b87a6004d4b785663257362d1658a729
runc version: b2567b37d7b75eb4cf325b77297b140ea686ce8f
init version: 949e6fa
Security Options:
 seccomp
  Profile: default
Kernel Version: 4.9.60-linuxkit-aufs
Operating System: Docker for Mac
OSType: linux
Architecture: x86_64
CPUs: 4
Total Memory: 1.952GiB
Name: linuxkit-025000000001
ID: SIHA:DUHM:EBQD:DRRR:E2MW:OGPK:4OIX:ECR5:NUVR:ZN7Y:634N:4ZZI
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): true
 File Descriptors: 21
 Goroutines: 39
 System Time: 2018-01-17T17:30:12.21134331Z
 EventsListeners: 2
HTTP Proxy: docker.for.mac.http.internal:3128
HTTPS Proxy: docker.for.mac.http.internal:3129
Registry: https://index.docker.io/v1/
Labels:
Experimental: true
Insecure Registries:
 127.0.0.0/8
Live Restore Enabled: false