Docker Community Forums

Share and learn in the Docker community.

Docker CentOs does not communicate with the 172.17.7[4-5] .xx

Dear

Through this request, I come from the community to support the resolution of the following scenario.

I have a docker layer running on a Windows server. This Windows server has the IP (172.19.16.147 / gateway 172.19.16.1 / 255.255.255.0).
The docker runs / starts the “CentOS 7.7” operating system.

The problem is not in the Docker CentOS in not being able to PING and / or close TELNET with network IP (s) (172.17.74.xx) or (172.17.75.xx) and being able to perform these commands for networks (172.21 .xx.xx and 172.25.xx.xx and 172.19.xx.xx).

The Windows server that starts Docker, is able to perform PING and TELNET for all networks, including one network (172.17.xx.xx).

Due to this behavior, there is a problem with Docker not being able to communicate with the network (172.17.xx.xx).

Below is the ifconfig:

[root @ 3c3025e02e49 /] # ifconfig
eth0: flags = 4163 <UP, BROADCAST, RUNNING, MULTICAST> mtu 1500
inet 172.19.16.1 netmask 255.255.255.0 broadcast 172.19.16.255
ether 02: 42: ac: 13: 10: 01 txqueuelen 0 (Ethernet)
RX Packets 59962449 bytes 56252354621 (52.3 GiB)
RX errors 0 discarded 0 exceeds 0 frame 0
TX Packets 76699162 bytes 15990011048 (14.8 GiB)
TX errors 0 discarded 0 exceeds 0 carrier 0 collisions 0

lo: flags = 73 <UP, LOOPBACK, RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
loop txqueuelen 1 (Local loopback)
RX Packets 209473979 bytes 30169591755 (28.0 GiB)
RX errors 0 discarded 0 exceeds 0 frame 0
TX Packets 209473979 bytes 30169591755 (28.0 GiB)
TX errors 0 discarded 0 exceeds 0 carrier 0 collisions 0

Below the route:

[root @ 3c3025e02e49 /] # route
IP kernel routing table
Destination Gateway Genmask Flags Metric Ref. Use Iface
default gateway 0.0.0.0 UG 0 0 0 eth0
172.19.16.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

[root @ 3c3025e02e49 /] # rota -en
IP kernel routing table
Genmask Destination Gateway Signals MSS irtt Iface window
0.0.0.0 172.19.16.151 0.0.0.0 UG 0 0 0 eth0
172.19.16.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

On Linux systems, Docker uses the subnet 172.17.0.0/16 for the docker0 interface dy default.
If you enabled Docker Swarm, then the interface docker_gwbridge will use the subnet 172.18.0.0/16 additionaly.

You high likely have an ip range collision between your LAN subnet and the docker interface’s subnet… Either change your LAN’s subnet ip range or change the ip range for the subnet of the docker interfaces…