Docker Community Forums

Share and learn in the Docker community.

Docker CLI and docker Desktop for Mac produce different lists of images

I expected that the Docker CLI and the Docker Desktop for Mac would produce the same list of images.
They don’t. When I run the docker CLI I get a list of all images that are stored locally:

~/RAP % docker images
REPOSITORY                               TAG           IMAGE ID       CREATED         SIZE
ampersandtarski/gatling                  3.7.2         98b191db38f3   6 minutes ago   189MB
ampersandtarski/enroll                   latest        7e7f5c1c9cea   7 minutes ago   950MB
mariadb                                  10.4          77bc2af93775   5 months ago    400MB
phpmyadmin/phpmyadmin                    latest        2e5141bbcbfb   7 months ago    474MB
traefik                                  v2.2          f965f5a1fff8   16 months ago   79.4MB
pmsipilot/docker-compose-viz             latest        571541d040a1   16 months ago   132MB
denvazh/gatling                          3.2.1         1608e0e25e50   2 years ago     180MB
~/RAP %

Yet, in the docker Desktop for Mac, I get an empty list of images, even though it does display all of my running containers:

Does anyone have a clue as to what I’m doing wrong? Any help is appreciated.

I’m running on:

  • macOS Big Sur vs. 11.6.
  • Docker version 20.10.8, build 3967b7d
  • Docker Desktop version 3.6.0.5487

This issue has similarities with this issue.

That issue is different. Your images did not disappear, only Docker Desktop does not show them. Have you tried to restart Docker Desktop? Occasionally I run into similar issues where the Desktop cannot show something that the CLI can. And I don’t use the desktop very often. Restarting Docker Desktop always solved it.