Docker Community Forums

Share and learn in the Docker community.

Docker-cloud CLI install fails on PyYAML version 5.3.1 installed

Running on Ubuntu 21.04 Python version 3.9.4
pip 21.0.1 from /usr/local/lib/python3.9/dist-packages/pip (python 3.9)

sudo pip3 install docker-cloud

fails on incompatible PyYAML version.
It is looking for PyYAML<4,>=3 - which seems very old.

Any suggestions please?


Collecting docker-cloud
Using cached docker_cloud-1.0.9-py3-none-any.whl
Requirement already satisfied: six<2,>=1.3.0 in /usr/local/lib/python3.9/dist-packages (from docker-cloud) (1.14.0)
Requirement already satisfied: future<1,>=0.15.0 in /usr/local/lib/python3.9/dist-packages (from docker-cloud) (0.18.2)
Requirement already satisfied: requests<3,>=2.5.2 in /usr/lib/python3/dist-packages (from docker-cloud) (2.25.1)
Collecting python-dockercloud<2,>=1.0.11
Using cached python_dockercloud-1.0.12-py3-none-any.whl
Requirement already satisfied: tabulate<1,>=0.7 in /usr/lib/python3/dist-packages (from docker-cloud) (0.8.7)
Collecting ago<0.1,>=0.0.6
Using cached ago-0.0.93-py3-none-any.whl
Collecting PyYAML<4,>=3
** Using cached PyYAML-3.13-cp39-cp39-linux_x86_64.whl**
Requirement already satisfied: websocket-client<1,>=0.32.0 in /usr/local/lib/python3.9/dist-packages (from docker-cloud) (0.56.0)
Requirement already satisfied: python-dateutil<3,>=2 in /usr/lib/python3/dist-packages (from docker-cloud) (2.8.1)
Installing collected packages: PyYAML, python-dockercloud, ago, docker-cloud
** Attempting uninstall: PyYAML**
** Found existing installation: PyYAML 5.3.1**

Thank you for your help and suggestions.
Mono