Docker Community Forums

Share and learn in the Docker community.

Docker command in an exist container


(Tacnoman) #1

Hello guys.

I’m a new user in Docker.
I created two files: Dockerfile and docker-compose.yml for a rails application.

I ran ‘docker-compose run groovecollab_website’ to create a m container with my exist project. The container was created but the bundle command returned an error. I want to access this container to install manually, but I have a problem.

To access a container I ran ‘docker exec -it name_of_project bash’ and I received this error.
Error response from daemon: Container name_of_project is not running

I tried to start this container with command:
docker start -a my_container_id
And I received:
Could not find minitest-5.7.0 in any of the sources
Run bundle install to install missing gems.

I cannot start because the COMMAND this container is “bundle exec rails s”

CONTAINER ID COMMAND
b6c3e455f748 “bundle exec rails s”

How can I solve this?


(Ranjandas) #2

Hi, tacnoman,

Instead of trying to fix this by entering into the container try to identify the root cause behind the docker build breaking from the Dockerfile. Manually making changes will defeat the purpose of dockerfile.

Identify why bundle install is breaking, fix it and try to get a successful docker build.

Regards