Docker command-line is not working

I am using VM of below details:

Linux ctuser-virtual-machine 4.10.0-28-generic #32~16.04.2-Ubuntu SMP Thu Jul 20 10:19:48 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

I have installed docker. and if I run docker -v I can get version details:

Docker version 17.06.0-ce, build 02c1d87

dockerd daemon is also running

But when I am trying to run any command its always give the help page like below:
Usage: dockerd COMMAND

A self-sufficient runtime for containers.

–add-runtime runtime Register an additional OCI compatible runtime (default [])
–allow-nondistributable-artifacts list Allow push of nondistributable artifacts to registry
–api-cors-header string Set CORS headers in the Engine API
–authorization-plugin list Authorization plugins to load
–bip string Specify network bridge IP
-b, --bridge string Attach containers to a network bridge
–cgroup-parent string Set parent cgroup for all containers
–cluster-advertise string Address or interface name to advertise
–cluster-store string URL of the distributed storage backend
–cluster-store-opt map Set cluster store options (default map[])
–config-file string Daemon configuration file (default “/etc/docker/daemon.json”)
–containerd string Path to containerd socket
–cpu-rt-period int Limit the CPU real-time period in microseconds
–cpu-rt-runtime int Limit the CPU real-time runtime in microseconds
–data-root string Root directory of persistent Docker state (default “/var/lib/docker”)
-D, --debug Enable debug mode
–default-gateway ip Container default gateway IPv4 address
–default-gateway-v6 ip Container default gateway IPv6 address
–default-runtime string Default OCI runtime for containers (default “runc”)
–default-shm-size bytes Default shm size for containers (default 64MiB)
–default-ulimit ulimit Default ulimits for containers (default [])
–disable-legacy-registry Disable contacting legacy registries (default true)
–dns list DNS server to use
–dns-opt list DNS options to use
–dns-search list DNS search domains to use
–exec-opt list Runtime execution options
–exec-root string Root directory for execution state files (default “/var/run/docker”)
–experimental Enable experimental features
–fixed-cidr string IPv4 subnet for fixed IPs
–fixed-cidr-v6 string IPv6 subnet for fixed IPs
-G, --group string Group for the unix socket (default “docker”)
–help Print usage
-H, --host list Daemon socket(s) to connect to
–icc Enable inter-container communication (default true)
–init Run an init in the container to forward signals and reap processes
–init-path string Path to the docker-init binary
–insecure-registry list Enable insecure registry communication
–ip ip Default IP when binding container ports (default
–ip-forward Enable net.ipv4.ip_forward (default true)
–ip-masq Enable IP masquerading (default true)
–iptables Enable addition of iptables rules (default true)
–ipv6 Enable IPv6 networking
–label list Set key=value labels to the daemon
–live-restore Enable live restore of docker when containers are still running
–log-driver string Default driver for container logs (default “json-file”)
-l, --log-level string Set the logging level (“debug”|“info”|“warn”|“error”|“fatal”) (default “info”)
–log-opt map Default log driver options for containers (default map[])
–max-concurrent-downloads int Set the max concurrent downloads for each pull (default 3)
–max-concurrent-uploads int Set the max concurrent uploads for each push (default 5)
–metrics-addr string Set default address and port to serve the metrics api on
–mtu int Set the containers network MTU
–no-new-privileges Set no-new-privileges by default for new containers
–oom-score-adjust int Set the oom_score_adj for the daemon (default -500)
-p, --pidfile string Path to use for daemon PID file (default “/var/run/”)
–raw-logs Full timestamps without ANSI coloring
–registry-mirror list Preferred Docker registry mirror
–seccomp-profile string Path to seccomp profile
–selinux-enabled Enable selinux support
–shutdown-timeout int Set the default shutdown timeout (default 15)
-s, --storage-driver string Storage driver to use
–storage-opt list Storage driver options
–swarm-default-advertise-addr string Set default address or interface for swarm advertised address
–tls Use TLS; implied by --tlsverify
–tlscacert string Trust certs signed only by this CA (default “/root/.docker/ca.pem”)
–tlscert string Path to TLS certificate file (default “/root/.docker/cert.pem”)
–tlskey string Path to TLS key file (default “/root/.docker/key.pem”)
–tlsverify Use TLS and verify the remote
–userland-proxy Use userland proxy for loopback traffic (default true)
–userland-proxy-path string Path to the userland proxy binary
–userns-remap string User/Group setting for user namespaces
-v, --version Print version information and quit

Run ‘dockerd COMMAND --help’ for more information on a command.

I am not able to figureout the problem

What command are you attempting to run? Have you tried the hello-world image:
docker run hello-world?

yeah!! I have tried. For any command it is showing the help page!!

I recommend starting over following the guide below. If that doesn’t work, let us know if there are any error messages during install.

I have followed the same for the installation,and I have not facing any
problem in installation. Installation is successfully done.The dockerd
thread also running. but whenever I am trying to run any command I am
facing the problem.

Try using docker instead of dockerd.
docker ps -a
Let me know if that works.

I am using docker only. Like…
“docker images” etc

The help page you listed above is for the dockerd command. I am uncertain how this would be displayed unless the two were pointing to the same inode.
if [ $(which docker) -ef $(which dockerd) ]; then echo yes; fi
Will output yes if the files are identical (inode). If they are, there is some sort of error in relation to the install since these files should never point to the same inode.

I am not sure what else to suggest here as this is not the usual behavior for docker and I was unable to reproduce the symptoms you are experiencing.

Yeah!! That’'s what I am also confused.I have tried almost 5-6 times. But
same result.
I have already installed docker in one VM by following the steps what ever
you have mentioned in the link.
I don’t know,what mistake I am doing here :frowning: