Docker Compose and Azure Artifacts Store Connection for local dev environment

I’m new to Docker and am having an issue. I’m working on a new project that will be hosted in Azure and in creating my local dev environment spun up a container for Azure functions. I’ve used Visual Studio 2022 to create the Docker Compose script.
My solution in Visual Studio has 4 projects in it, one of the projects is an azure function API. 2 of these projects pull from our internal artifacts/nuget store that is hosted in Azure Dev Ops. I’ve added Docker Compose to my solution and when I run the solution I can hit the API and everything works. When I stop debugging with Visual Studio, I can no longer communicate with the API.

When I run the Docker Compose Up command on the command prompt, I get an error that says “error NU1301: Unable to load the service index for source

I’ve looked at the logs and there is nothing that gives me more information as to why we’re getting this error.

The API container is connected to the bridge network.

All of the dotnet restore and dotnet build commands run on my local laptop but fail when running the “Docker Compose Up” command.