Docker compose doesn't auto complete anymore

I use docker compose command to start my stack.
Normally I can also start and stop a container with the command this works fine.

So for example docker compose stop portainer

What I found out is that version 25 on a Raspberry PI running on 64Bit Bookworm Raspberry OS won’t autocomplete anymore.

so if I type docker compose stop por{tab} it doesn’t complete it anymore.

And I know this has worked in the past. Is there a change or is this a bug?

1 Like


When you install docker it should install the autocomplete files.
Do you have this file: /usr/share/bash-completion/completions/docker ?

also can you provide the result of:

apt list bash-completion

I do have that command.

This is the output of the command :

pi@pi-server:~ $ apt list bash-completion
Listing… Done
bash-completion/stable,stable,now 1:2.11-6 all [installed]

Command auto completing is ok it is more the container name auto completion that is not working wel.

Same issue here, docker compose is not completing the service names

1 Like

Same issue here on Ubuntu. I’ve been using this for ages. After last update it doesn’t work anymore.

1 Like

+1 - except specifically I’m getting a list of services, just no partial completion. If I try to use docker compose logs postgr<TAB> I just get a full list of services rather than the only possible match, postgres in my case


This might be relevant

Yesterday I did an apt update and there was a new update for docker. I works now fine om my test environment but on my “production” environment it still is not working. Compared the version and all are the same. Is there something else I can check?