Docker Community Forums

Share and learn in the Docker community.

Docker compose mounting empty volumes

docker

(Frondor) #1

Expected behavior

docker-compose up -d should properly mount the volumes

Actual behavior

Suddenly (it worked perfectly two days ago, didn’t install anything nor updated OS), the volumes are no longer being mounted. Don’t see any error message, only the container logs complaining that command can’t find the file (because the “empty” volume overrides the container’s copied files).

If I remove ./service:/home/node/api volume, then docker uses the files in the container and everything works fine.

Information

  • Docker version 18.03.0-ce, build 0520e24302 (Docker toolbox / boot2docker / virtualbox 5.2.12)
  • docker-compose version 1.20.1, build 5d8c71b2
  • Windows 7 x64
  • Virtual box sharing folder.jpg

Already tried removing the docker machine from virtualbox and creating it again, pruning all volumes / images and containers. Even reinstalling Docker Toolbox, but issue persist.

Everything is ran with administrator rights.

More info

docker-compose config outputs

services:
  api:
    build:
      context: C:\users\fede\documents\test\service
    container_name: api
    ports:
    - 3000:3000/tcp
    volumes:
    - /c/users/fede/documents/test/service:/home/node/api:rw
version: '3.0'

$ docker inspect api outputs: https://pastebin.com/1zQ3vjFi

Files

I’ve simplified a sample app in order to make debug faster, you can see it here: https://github.com/Frondor/simple-node-app

I’m pretty new at docker, but if there’s something else I can provide in order to start using docker locally again, just ask in the comments. But honestly, this started happening from one day to another without doing any changes to the system. No anti-virus involved.


(Rruiztyris) #2

Try disabling shared drive in docker settings and run a docker compose command. Docker will request you access to the drives it needs to link to. Then, share that drives in the dialog box. It worked for me.


(Eli7vh) #3

I have tried this several times without success. Any other ideas?


(Jan Killian) #4

Had the same issue.
Works ok for me after today’s docker update and re-enabling the share of drive C..
Here’s the minimal issue reproduction that was failing for me before and works ok now.