Docker Community Forums

Share and learn in the Docker community.

Docker-compose port mapping breaks when connecting container to network


(Justin Bodnar) #1

I have a docker-compose file that instantiates an OpenVPN container with ports mapped “1194:1994/udp” and connects it to a macvlan network for port-forwarding. When I began work on this file I was successful in connecting to the VPN from beyond my firewall. Somewhere during my addition of new containers and networks I seem to have broken something. Now it’s only mapping the ports on OpenVPN when I don’t connect the container to any network. I’ve tried changing the mapping to things like “0.0.0.0:1194:1994/udp” and “10.64.0.101:1194:1194/udp” but nothing has worked.

The command I’m running is: docker-compose up -d

A copy of the docker-compose file can be found at https://pastebin.com/ndAk0Kf4 . Sorry for the external link, but posting YAML in this submission box is a nightmare.

Here’s a screenshot of the output from ‘docker container ls’ showing that the ports aren’t being mapped properly.

Any help would be greatly appreciated.

( docker --version )
Docker version 18.05.0-ce, build f150324

( docker-compose --version )
docker-compose version 1.20.0, build ca8d3c6

( uname -a )
Linux dockerhost03 4.9.0-7-amd64 #1 SMP Debian 4.9.110-1 (2018-07-05) x86_64 GNU/Linux