Docker Community Forums

Share and learn in the Docker community.

Docker-compose up -d | could not find plugin bridge in v1 plugin registry: plugin not found

Trying to run docker-compose up -d using a yml file configuration. Receiving the error: ERROR: could not find plugin bridge in v1 plugin registry: plugin not found

Using a AWS Windows 2019 instance.

Windows Server 2019 Datacenter
Version 1809
OS Build : 17763.1457

docker-compose version
docker-compose version 1.27.4, build 40524192
docker-py version: 4.3.1
CPython version: 3.7.4
OpenSSL version: OpenSSL 1.1.1c 28 May 2019

docker version
Client: Docker Engine - Enterprise
Version: 19.03.11
API version: 1.40
Go version: go1.13.11
Git commit: 0da829ac52
Built: 06/26/2020 17:20:46
OS/Arch: windows/amd64
Experimental: false

Server: Docker Engine - Enterprise (this node is not a swarm manager - check license status on a manager node)
Engine:
Version: 19.03.11
API version: 1.40 (minimum version 1.24)
Go version: go1.13.11
Git commit: 0da829ac52
Built: 06/26/2020 17:19:32
OS/Arch: windows/amd64
Experimental: true

docker-compose config
networks:
commerce:
driver: bridge
services:
data-query:
depends_on:
elasticsearch:
condition: service_started
redis:
condition: service_started
zookeeper:
condition: service_started
environment:
ENVTYPE: toolkit
LICENSE: accept
NLP_ENABLE_LANGUAGE_CODE: EN
TX_HOST: tk. commerce. com [remove space in between]
healthcheck:
test: curl -f -k -sS https:// localhost: 30901 [remove space in between]
image: commerce/search-query-app:9.1.2.0
networks:
commerce: null
ports:
- published: 30920
target: 30900
- published: 30921
target: 30901
volumes:
- C:\WCDE_V9\workspace\HCLDevOps\docker-compose\hcl-cache-search:/SETUP/hcl-cache:rw
elasticsearch:
environment:
ES_JAVA_OPTS: -Xmx4096m -Xms1024m
cluster.name: docker-cluster
discovery.type: single-node
indices.query.bool.max_clause_count: 100000
network.host: 0.0.0.0
xpack.monitoring.collection.enabled: “true”
image: docker.elastic.co/elasticsearch/elasticsearch:7.8.0
networks:
commerce: null
ports:
- published: 30200
target: 9200
- published: 30201
target: 9300
volumes:
- C:\WCDE_V9\workspace\HCLDevOps\docker-compose\elasticsearch\data:/usr/share/elasticsearch/data:rw
- C:\WCDE_V9\workspace\HCLDevOps\docker-compose\elasticsearch\config:/etc/elasticsearch/config:rw
ingest:
depends_on:
nifi:
condition: service_started
environment:
ENVTYPE: toolkit
LICENSE: accept
healthcheck:
test: curl -f -k -sS https:// localhost: 30801/ health [remove space in between]
image: commerce/search-ingest-app:9.1.2.0
networks:
commerce: null
ports:
- published: 30800
target: 30800
- published: 30801
target: 30801
volumes:
- C:\WCDE_V9\workspace\HCLDevOps\docker-compose\hcl-cache-search:/SETUP/hcl-cache:rw
nifi:
depends_on:
data-query:
condition: service_started
registry:
condition: service_started
environment:
AUTH_JDBC_DRIVER_CLASSNAME: com.ibm.db2.jcc.DB2Driver
AUTH_JDBC_DRIVER_LOCATION: /opt/nifi/nifi-current/lib/db2jcc4.jar
AUTH_JDBC_URL: jdbc:db2://tk.commerce.com:50000/wcsdb
AUTH_JDBC_USER_NAME: wcs
AUTH_JDBC_USER_PASSWORD: passw0rd#
LICENSE: accept
NIFI_LOG_DIR: /opt/nifi/nifi-current/dockerdata/logs
NLP_ENABLE_LANGUAGE_CODE: EN
REDIS_HOST: redis
REDIS_PORT: ‘6379’
healthcheck:
test: curl -f -sS http:// localhost: 30600 [remove space in between]
image: commerce/search-nifi-app:9.1.2.0
networks:
commerce: null
ports:
- published: 30600
target: 30600
- published: 30606
target: 30606
- published: 30700
target: 30700
volumes:
- C:\WCDE_V9\workspace\HCLDevOps\docker-compose\nifi\data:/opt/nifi/nifi-current/dockerdata:rw
redis:
environment:
ALLOW_EMPTY_PASSWORD: “yes”
image: bitnami/redis:6.0.6
networks:
commerce: null
ports:
- published: 6379
target: 6379
volumes:
- C:\WCDE_V9\workspace\HCLDevOps\docker-compose\redis\data:/bitnami/redis/data:rw
registry:
environment:
LICENSE: accept
healthcheck:
test: curl -f -sS http://localhost:30400/nifi-registry-api/buckets | grep Default [remove space in between]
image: commerce/search-registry-app:9.1.2.0
networks:
commerce: null
ports:
- published: 30400
target: 30400
zookeeper:
environment:
ALLOW_ANONYMOUS_LOGIN: “yes”
image: bitnami/zookeeper:3.6.1
networks:
commerce: null
ports:
- published: 2181
target: 2181
- published: 2888
target: 2888
- published: 3888
target: 3888
volumes:
- C:\WCDE_V9\workspace\HCLDevOps\docker-compose\zookeeper:/bitnami/zookeeper:rw
version: ‘3.3’

docker info
Client:
Debug Mode: false
Plugins:
cluster: Manage Docker Enterprise clusters (Mirantis Inc., v1.4.0)

Server:
Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 4
Server Version: 19.03.11
Storage Driver: windowsfilter (windows) lcow (linux)
Windows:
LCOW:
Logging Driver: json-file
Plugins:
Volume: local
Network: ics internal l2bridge l2tunnel nat null overlay private transparent
Log: awslogs etwlogs fluentd gcplogs gelf json-file local logentries splunk syslog
Swarm: inactive
Default Isolation: process
Kernel Version: 10.0 17763 (17763.1.amd64fre.rs5_release.180914-1434)
Operating System: Windows Server 2019 Datacenter Version 1809 (OS Build 17763.1457)
OSType: windows
Architecture: x86_64
CPUs: 8
Total Memory: 32GiB
Name: EC2AMAZ-L39QGAO
ID: 2WJ3:3ZQC:Y53M:YH2T:6S3G:XS5B:K6DQ:JRGL:YXIK:7LOA:U4W5:BTRK
Docker Root Dir: C:\ProgramData\docker
Debug Mode: false
Registry: https:// index. docker. io /v1/ [remove space in between]
Labels:
Experimental: true
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false
Product License: this node is not a swarm manager - check license status on a manager node

A Newbie to the docker world, any pointers to move forward will be highly appreciated. Thanks in advance.