Docker Community Forums

Share and learn in the Docker community.

Docker-compose up -d crashes Linux

Having a nightmare trying to work this out. It seems linked to docker as I can reproduce this but I appreciate it may be something wrong in Linux. Hoping someone can shed some light on this please.

I’m on Ubuntu 16.04 LTS. Docker(dot)io installed.
Docker version 18.09.7, build 2d0083d.
docker-compose version 1.22.0, build f46880fe.
These versions worked fine so I’m trying to resolve the problem.

I’ve worked with it fine and have multiple projects but some have begun consistently crashing Linux (fsck clean followed by login screen) once they appear to have completed. I have got around it by not running them in detached mode but it isn’t always the case I think.

I have run commands like:
docker system prune -a --volumes
sudo apt-get install --reinstall docker.io
sudo curl -L ttps://github.com/docker/compose/releases/download/1.22.0/docker-compose-uname -s-uname -m -o /usr/local/bin/docker-compose

I always get this appear in this log and I believe veth is docker but don’t know how to interpret this
/var/log/kern.log:
https://pastebin.com/fBFcMS99

(had to edit docker-compose url and ad (dot) in dockerid as new users are only allowed 2 links)