Docker Container Network Connectivity Issue on Linux: 'This site can’t be reached' error

I have have a Docker container running on Linux Machine. When I tried to access it on Browser it says

This site can’t be reached 10.xxx.xx.xx took too long to respond.
Try: 

Checking the connection
Checking the proxy and the firewall
Running Windows Network Diagnostics

This this is my entrypoint.sh file. This file is being used by Docker

exec gunicorn --bind 0.0.0.0:${PORT:-8000} --timeout 300 -w 4 -t 4 wtools2.wsgi:application

Also If I run netstat -tuln command it shows following

Active Internet connections (only servers)

Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN
tcp        0      0 xx.xx.xx.xx:8000        0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:10050           0.0.0.0:*               LISTEN
tcp        0      0 xx.xx.xx.xx:5000        0.0.0.0:*               LISTEN

I also asked our Network Engineer to check any communication blocks He says

‘the communication flow is allowed from network side, no restriction for whole subnet’

Did you try to access it with IP and port?

Yes. I tried with Actual Port and Ip address on which docker container is running but it did not work.

The problem is that same configuration worked on another server. Do you think it related any type of network or firewall blockage?

You can try to access the port in the node itself.

I wonder why it would say Windows Network if you are on a Linux machine unless it is a virtual Linux machine.

A little bit more context about what you actually run and how could help.

If you have a Vm in which Docker containers are, the IP of a container won’t work.