Docker Community Forums

Share and learn in the Docker community.

Docker container start/stop

Hello,

I’m facing some problem with a Synology RS815RP+ with docker installed, DSM 7.0.1-42218.

I have a container with domoticz google assistant installed, the container starts and suddenly stops after some seconds, the container log report the error:

“/entrypoint.sh: line 144: 15 Killed pip install $PIP_FLAGS --upgrade pip”

Anyone could help me to fix this issue?

Thank you very much

I don’t know what caused it in your environment but I had a similar error message using python virtual environment. I was not surprised since I tried to use an old python version on my Mac. It was the first time I got this error message and it was just today. I show how I could reproduce it. It might help you or someone else find a solution for you.

 ✘ ta@ta-mb  ~ 
 »  virtualenv --python python2 venv
created virtual environment CPython2.7.18.final.0-64 in 129ms
  creator CPython2macOsFramework(dest=/Users/ta/venv, clear=False, no_vcs_ignore=False, global=False)
  seeder FromAppData(download=False, pip=bundle, setuptools=bundle, wheel=bundle, via=copy, app_data_dir=/Users/ta/Library/Application Support/virtualenv)
    added seed packages: pip==20.3.4, setuptools==44.1.1, wheel==0.36.2
  activators BashActivator,CShellActivator,FishActivator,PowerShellActivator,PythonActivator
 ta@ta-mb  ~ 
 »  source venv/bin/activate
(venv)  ta@ta-mb  ~ 
 »  pip --version
[1]    21865 killed     pip --version

What version of Python are you using?

Hello rimelek and thank you very much for your reply!

I have v3.8.8
python

In the packages center I have installed all the packages: Python2, Python 3.10, Python 3.8, Python3

In Domoticz forum I have added some more details about the problem, is the latest post:
https://www.domoticz.com/forum/viewtopic.php?f=69&t=31869&start=220

Thank you very much :pray:

So you are saying you have Python 3.8.8 but it is Python 3.7.3 in the details on the Domoticz forum you mentioned. So where is is Python 3.8.8 and where is Python 3.7.3?

If you have multiple python versions in the container, is the “pip” command using Python 3 or Python 2? Can you run the a container from the same image and try pip --version ?

Hello,

yes the problem is that I don’t know how to uninstall the current v3.8.8 and install the v3.7.3.

Here the screen when I check the pip - - version