Docker Community Forums

Share and learn in the Docker community.

Docker Desktop 2.0.0.3 for Windows with linux container not starting

#1

Hello

I did not find a solution so far. I have installed Docker Desktop 2.0.0.3 on Windows 10 Enterprise, Version 1809.
Hyper V is completely enabled.

But after fresh installation of Docker, I only get the message:

Unable to create: Der ausgeführte Befehl wurde beendet, da die Einstellungsvariable “ErrorActionPreference” oder ein allgemeiner Parameter auf “Stop” festgelegt ist: Fehler beim Zugreifen auf ein Objekt auf dem Computer “LAPTOP-GR4NELVD”, da das Objekt nicht gefunden wurde. Möglicherweise wurde es gelöscht. Vergewissern Sie sich, dass auf dem Computer der Verwaltungsdienst für virtuelle Computer ausgeführt wird.

So docker complains, that the “Virtual Machine Management Servive” is not enabled/available.

But it is.

I also deactivated/activated Hyper-V, re-installed Docker, but nothing is helping.

Switching to windows-container in docker is working, but I need the linux container.

Does anyone face this problem and found a solution?

Thanks!

(Tekki) #2

I had a similar problem some days ago on Win 10 Pro and I solved it with the installation of Desktop 2.0.4.1 from the edge channel. Because it worked afterwards I didn’t look closer at it, but maybe it is related to a Windows update (KB4493464?).
By the way, this was reported on Github in 3891, so the issue you opened there is a duplicate.

#3

Thanks for the hint. But edge 2.0.4.1. is causing the same issue.
I could make it all work with Docker Toolbox which is using VirtualBox…
I closed the doubled ticket, but seems, another person just opened one. So seems, several guys got that issue.

#4

Got the same issue. Edge version 2.0.4.1 works however it’s extremly slow with docker-compose down or docker stop. Some containers won’t stop at all and require a complete reinstall of Docker. My i9 is hardly doing anything. Takes like 2 hours to run docker-compose up -d.

#5

Thanks for the info. Gladly Toolbox with VirtualBox suits my requirements for now. So I can wait, until the stable version will work fine with Hyper-V.