Docker Desktop 4.27.1 - cannot login with Chrome but Safari works

After upgrading to 4.27.1 I noticed that Docker Desktop wasn’t logged in. Clicking the Login button in Desktop Client opened the default works (Chrome) where I logged in to my Docker account, but the final screen with the open Docker Desktop button did not open Docker Desktop app.
Setting the default browser to Safari and trying again worked.

I upgraded Docker Desktop on my Mac just now to v4.27.1. I tried to sign out and in before that and after that. Worked with Google Chrome. Then I noticed my Chrome was not up to date, so I updated it and tried again. It still worked, so I could not reproduce the issue.

ok. maybe I have some extension preventing Chrome from opening Docker Desktop :person_shrugging:

I am also experiencing this on Windows after updating to 4.27.1. Both Chrome and Edge fail to open the Docker Desktop app after signing in and clicking the button.

I just checked again and I am now signed in, so that was strange.