Docker Desktop doesn't show UI on Windows 11 Pro

I started Docker Desktop on Windows 11 and it didn’t show any UI or tray icon. But in the Task Manager all processes are working.
I tried to reinstall it many times and check/uncheck Hyper-V, but nothing helped.

Is there at least a “Docker” meni item in the start menu or on the desktop?

Yes, I start it from the Start Menu. All processes are running ok in the Task Manager. I don’t have UI and tray icon

Some ideas I can think of.

1 Like

Hi. Thanks for your recommendations, but they didn’t help me((

  1. No, I’m using only one monitor.
  2. I have only Microsoft Security. I tried to switch it off and tried to reinstall Docker without the internet, but it didn’t help either.
  3. The command “docker ps” doesn’t work.
  4. I tried the sefl-diagnose tool but in the logs all is OK.

Then the problem is not just the GUI.

I know that there are some Windows services so you could check those in the list of Windows services. You could try to check the Windows Event logs and also make sure you are trying to install it as an Administrator user. There is a folder in your users home called “.docker”. You can delete that before reinstalling. That is not Windows related just a general advice.

I tried my best, but I work on macOS and Linux, so I think I’m out of ideas if the above recommendations don’t help. You can wait here for more people or try to report it on GitHub:

1 Like

Hi! Tnx for your help. My problem was solved after uninstalling Docker, cleaning the register, and reinstalling Docker.