Docker Community Forums

Share and learn in the Docker community.

Docker Desktop Fails to start on Mac OS X 10.15 beta 1 (19A471t)

Hi,

attempting to run latest docker desktop on OS X 10.15, beta 1 (19A471t): docker starts to load as usual, but ultimately fails and shuts down.

Happy to provide any log file etc.

thanks,
Stephen.

just attempted with fresh download. no change.

update: opening docker from Apps with the option key selected seemed to allow it to boot successfully.

1 Like

How did you get it to work? are you talking about booting it from the Applications folder, as it doesn’t exist in the App store.

doubleclicking on docker in the apps folder with the option/cmd key seems to allow docker to startup correctly - so it would appear to be a permissions issue, as opening any app with that key depressed opens the app as ‘root’.

Thanks for replying, but this doesn’t work for me. It may open Docker, but after it actually starts up, it crashes.

sorry to hear that. I’ve no suggestions I’m afraid. Hopefully a docker expert might pitch in. all the best.

No problem, Stephen. I appreciate you taking the time to respond!

Okay, I found a solution for anybody else having this issue. If you go into /Applications/Docker.app/Contents/MacOS/ and then hold down option+command (as Stephen mentioned) on the Docker unix executable and double click, it will open Docker in terminal it will work! Be aware, if you close Terminal it will kill the Docker process.

Interestingly, this morning, my more simple solution of Optioon+Command clicking the Docker app in the applications folder stopped working for me.

I can confirm that Karl’s solution works.

cheers Karl :slight_smile:

1 Like

Both methods still fail to work for me. Even running in terminal crashes. Any other ideas?

The same issue here. None of the above solutions worked for me.

Dunno if u have tried the following yet. Install the edge version of docker parallel to the stable version. Then start the edge version, let it do it’s stuff. If u already using the edge version, get the stable and start it.

Everytime one version fails to start, try the other version.

This is the way I get it running since day one of macOS beta.

Hi all,

Beta 2 of macos resolves the issue. I have also heard of others who resolved the permissions issues by runnign disk utility over their os disk.

regards,
Stephen.