Docker Desktop spins eternally

I’ve installed Docker Desktop but haven’t been able to work with it. Whenever I try to start Docker Desktop, it tells me it’s “Starting the Docker Engine” with a spinner and then does nothing else whatsoever. At all. Nada. Zip. Zilch. It’s fully locked on “starting its engine” and spins away forever.

It will not stop spinning. It really loves to spin and do nothing else. Kind of like a crazy dog I once owned who loved chasing his own tail.

Before anyone tells me about WSL, I have set up Docker (or so I thought) to use Hyperv on my Windows computer. Not WSL. So the pair of commands I’ve seen mentioned a million times will have zero impact on this. To be clear, I ran them anyway, fruitlessly, knowing people would insist I run them anyway.

Well, I did. And they accomplished nothing.

Any suggestions would be helpful. Ones I haven’t seen millions of doing Google searches.

Running Docker Desktop 4.87.0 on Windows 11 Pro 25H2 build 26200. Thank you.

Nobody would ask you to run wsl commands when you are not using WSL at all. I hope you have not seen that on this forum at least.

The problem is that people will not know what you have found and tried, so you could still get recommendations that you have already Googled and found a million times. The other problem is that these errors are hard to solve as “Docker engine is starting” is just a symptom. That is why people are mostly guessing and recommending whatever they can think of.

You probably also found a bunch of topics where we recommended running diagnostics and sharing it with the Docker staff on GitHub as the troubleshooting guide recommends

That allows the Docker staff to see your logs and notice possible causes.

I also often recommended running docker desktop logs which gives a single output compared to a lot of log files as a first step. I tried that sometimes too, but I don’t remember any case when I was able to tell the exact problem, so in these not obvious cases the best source of help is the Docker staff.

As a community here we can still try to help with the usual answers or there is a chance someone recognizes something in the output of docker desktop logs if you share a part of it while you see the annoying “docker engine is starting” message on the GUI.

If we could run a shell in the virtual machine of Docker Desktop, that would allow us to investigate inside, but most of the recommendations are about running a docker container in the VM first, which you can’t if the daemon is not running. Since you are not using WSL, I cannot even recommend running a shell in the docker-desktop WSL distribution, but if you know how you can run a shell in a HyperV VM on Windows, you can try that..

I am also curious, so I can try to look for a way later, but I can’t guarantee I will find one. If I do, I will share that here.

Once you are in the VM, you can check if the dockerd process is running. If so, you can try to check the daemon logs.

If there is a way to download a docker client into the VM and you find the socket, you could also test if the daemon is running properly and only the Docker Desktop is not able to communicate with it.

I’m not sure you want to go so deep into Docker Desktop for debugging though. If not, hopefully the Docker staff can help you analyze the diagnostics as they know the most about Docker Desktop internals.

Thanks for the reply. As a decades-long IT pro, I am not fond of having to spend hours diagnosing stuff on my own (personal) systems. For the most part, if something doesn’t work as expected, I just get rid of it and move on to something that actually works. That I even bothered posting anything here is probably more effort than Docker is worth.

I did extract a log using the system Command Prompt and the command you provided because I’m otherwise unable to get to anything meaningful within the program itself. I did try to kick off its built in troubleshooter, but unsurprisingly (after spending maybe 5 minutes trying to do so) it reported “Diagnose Failed.”

FYI the log file (which is a vomit of random stuff) contains many iterations of this:

[2026-08-30T18:10:04.591910300Z][com.docker.backend.exe.hostsinjector] unable to watch: will retry: %!s(<nil>)
[2026-08-30T18:10:05.592365600Z][com.docker.backend.exe.hostsinjector] unable to watch: will retry: %!s(<nil>)
[2026-08-30T18:10:06.592686700Z][com.docker.backend.exe.hostsinjector] unable to watch: will retry: %!s(<nil>)
[2026-08-30T18:10:07.592929300Z][com.docker.backend.exe.hostsinjector] unable to watch: will retry: %!s(<nil>)
[2026-08-30T18:10:08.593191400Z][com.docker.backend.exe.hostsinjector] unable to watch: will retry: %!s(<nil>)
[2026-08-30T18:10:09.593845100Z][com.docker.backend.exe.hostsinjector] unable to watch: will retry: %!s(<nil>)
[2026-08-30T18:10:09.599533800Z][com.docker.backend.exe.apiproxy] still waiting for the engine to respond to _ping after 1h12m26.2823871s: HTTP 500:

I tried uploading the log file (redirected from the command using the > operator) but this site told me “Sorry, new users can not upload attachments.” If there’s a trick to getting it in here, I don’t know what it might be.

Understandable. Docker DEsktop can work great, but when there is a problem, it can also be hard to find. At least for us. The Docker staff could interpret the logs better, unless we can’t upload it, which also happened to me once. I whish I remembered something that helps here. Maybe I can ask someone what is the way when the diagnostics cannot be uploaded.

I increased your trust level to TL0 to TL1 that allows uploading attachments. If you think the log is safe to share (I checked mine, and I don’t see any private info in it, but mine also works currently) you have the right now.

Those logs may be the result of the docker daemon not running. I am not on Windows at the moment and the documentation, only mentioned the path of the log files when WSL2 is used, but you can still check if you find the dockerd.log file here:

%LOCALAPPDATA%\Docker\log\vm\dockerd.log

if that shows something useful about why it cannot start, we may find a way to make it work or we can report it.

UPDATE:

Ignore the path I recommended. It is an old log on my machine from 2025 only. I am looking for a newer log.

UPDATE2:

So it is actually the init.log that the documentation mentions. I just thought the dockerd log would contain daemon logs specifically. So you can also check

%LOCALAPPDATA%\Docker\log\vm\init.log