Docker Desktop starting

I have tried every solution possible on the internet(in the below link) , i also reinstall docker version 4.15.0. But i still stuck on Docker Desktop starting…

What is the issue with this ?

1 Like

I don’t speak turkish, I only recognized the language (hopefully correctly). Please, share error messages as formatted text s not as a screenshot (we cant quote it or search for it). If you can also share the translated version under the original, that can speed up understanding the issue and give you some idea.

If the turkish texts just normal status messages than what is that we should see on the screenshot?

The latest version is 4.17.1 and 4.18.0 is coming soon so if you reinstall Docker Desktop, unless you have an issue with the latest version, you should install that.

Sorry for not being clear enough. So my problem is when i want to start docker desktop it got stuck on Docker Desktop Starting… and it doesnt start. I tried several versions 4.15 , 4.17.1 but it didn’t solve the issue.

There is no error it got stuck while starting the docker and nothing happens forever.

1 Like

I’m running into the same problem with 4.18. Itr get stuck on the “Starting the Docker Engine…” screen, and eventually given an error message that is pretty non-descript.

The first FAIL line ofr the “dockererd.exe -check” output is:
[PASS] DD0027: is there available disk space on the host?
[PASS] DD0028: is there available VM disk space?
[PASS] DD0002: does the bootloader have virtualization enabled?
[SKIP] DD0018: does the host support virtualization?
[FAIL] DD0001: is the application running? Docker is not running
[PASS] DD0017: can a VM be started?
[PASS] DD0016: is the LinuxKit VM running?
[FAIL] DD0011: are the LinuxKit services running? failed to ping VM diagnosticsd with error: Get “http://ipc/ping”: open \.\pipe\dockerDiagnosticd: The system cannot find the file specified.

1 Like

Using the “Step 2 - Unregister Docker Desktop” described here worked for me

Please note:

  • I tried to start Docker the first time, I got an error dialog that WSL needs to be upgraded, and Docker Desktop directed me to troubleshooting, so I wan wsl --update
  • I restarted Docker and then I got stuck in “Starting the Docker Engine”, so I ran the instructions described above , that is, I ran wsl --unregister docker-desktop and wsl --unregister docker-desktop-data – then, it worked