Docker Community Forums

Share and learn in the Docker community.

Docker engine repository for 17.xx series (e.g. 17.03)


#1

This is happeing when I try to install docker-ce-17.03.3

# yum install docker-ce-17.03.3.ce  docker-ce-selinux-17.03.3.ce

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: ftp.unicamp.br
 * extras: ftp.unicamp.br
 * updates: ftp.unicamp.br
Package docker-ce-selinux is obsoleted by docker-ce-cli, trying to install 1:docker-ce-cli-18.09.0-3.el7.x86_64 instead
Resolving Dependencies
--> Running transaction check
---> Package docker-ce.x86_64 0:17.03.3.ce-1.el7 will be installed
--> Processing Dependency: docker-ce-selinux >= 17.03.3.ce-1.el7 for package: docker-ce-17.03.3.ce-1.el7.x86_64
Package docker-ce-selinux is obsoleted by docker-ce-cli, but obsoleting package does not provide for requirements
---> Package docker-ce-cli.x86_64 1:18.09.0-3.el7 will be installed
--> Processing Dependency: containerd for package: 1:docker-ce-cli-18.09.0-3.el7.x86_64
--> Running transaction check
---> Package containerd.io.x86_64 0:1.2.0-3.el7 will be installed
---> Package docker-ce.x86_64 0:17.03.3.ce-1.el7 will be installed
--> Processing Dependency: docker-ce-selinux >= 17.03.3.ce-1.el7 for package: docker-ce-17.03.3.ce-1.el7.x86_64
Package docker-ce-selinux is obsoleted by docker-ce-cli, but obsoleting package does not provide for requirements
--> Finished Dependency Resolution
Error: Package: docker-ce-17.03.3.ce-1.el7.x86_64 (docker-ce-stable)
           Requires: docker-ce-selinux >= 17.03.3.ce-1.el7
           Available: docker-ce-selinux-17.03.0.ce-1.el7.centos.noarch (docker-ce-stable)
               docker-ce-selinux = 17.03.0.ce-1.el7.centos
           Available: docker-ce-selinux-17.03.1.ce-1.el7.centos.noarch (docker-ce-stable)
               docker-ce-selinux = 17.03.1.ce-1.el7.centos
           Available: docker-ce-selinux-17.03.2.ce-1.el7.centos.noarch (docker-ce-stable)
               docker-ce-selinux = 17.03.2.ce-1.el7.centos
           Available: docker-ce-selinux-17.03.3.ce-1.el7.noarch (docker-ce-stable)
               docker-ce-selinux = 17.03.3.ce-1.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
# yum search --showduplicates docker-ce-selinux

docker-ce-selinux-17.03.0.ce-1.el7.centos.noarch : SELinux Policies for the open-source application container engine
docker-ce-selinux-17.03.1.ce-1.el7.centos.noarch : SELinux Policies for the open-source application container engine
docker-ce-selinux-17.03.2.ce-1.el7.centos.noarch : SELinux Policies for the open-source application container engine
docker-ce-selinux-17.03.3.ce-1.el7.noarch : SELinux Policies for the open-source application container engine


Why I can’t install v17.03?