Docker engine stopped (4.25.2)

I cannot get the docker engine to start.

macOS Monterey 12.4
MacBook Air m1
Docker desktop 4.25.2 (129061
Engine: 24.0.6
Compose: v2.23.0-desktop.1
Credential Helper: v0.7.0
Kubernetes: v1.28.2

I’ve tried uninstalling and re-installing DD multiple times now.

deleting through the application does not work, endless loop

deleting folders doesn’t help

rm -rf ~/Library/Group\ Containers/
rm -rf ~/Library/Containers/com.docker.docker
rm -rf ~/.docker

1 Like

I am having the same issue. Full reinstall and removing docker directories didn’t help either. My guess is latest update borked M1 users.

I’m an M1 user and I had no problem with the update. I had 4.24.2 just a minute ago and I could update to 4.25.2 and Docker Engine starts,

Since there was only one issue I could reproduce on Mac about in a year, but I alwys have the latest macOS too, if you have an older macOS, that could be the reason. As far as I know macOS 12.4 should still be supported, but the last couple of Docker Desktop issue son macOS were solved by updating to a newer macOS version.

I was a few versions behind the latest version of Monterey, after updating to 12.7.1 I can confirm docker is working now. Wish I had known that before nuking everything but, all good now.

OSX: Monterey 12.7.1
Docker: 24.0.6
Docker Desktop 4.25.2 (129061)