Docker Community Forums

Share and learn in the Docker community.

Docker : Error response from daemon Get https://registry-1.docker.io/v2/: net/http


(Sanutopia) #1

Hello Friends,

I am able to successfully install boot2docker on Windows-7 Ent after downloading Toolbox.

1.But after logging in with docker user when I am executing “docker run hello-world”, it is giving below error.

docker: Error response from daemon: Get https://registry-1.docker.io/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers).

2.Also, when I am executing “docker ps”, it is not showing any process / docker running.

3.When executing “docker-machine ls” it is showing => “sh: docker-machine: not found”

4.However, when I am executing “docker network ls”, it is showing below.

NETWORK ID NAME DRIVER SCOPE
653a9c140e12 bridge bridge local
c95cde77f189 host host local
468070312c48 none null local

I tried to search on this forum for the same problem.
There are discussions but not able to find any concrete solution which will help my case.
Hence I am posting this question.

Please advise how to fix this problem. I need to set it up soon because I need this for official POC.

Thanking you
Santanu


(Rajie24) #2

I am also getting the same error which you given how to fix this issue


(Leowunz) #3

I got the same problem with ubuntu today. It used to be good.