Docker Community Forums

Share and learn in the Docker community.

Docker for Mac Version rc2-beta16 sysctl missing in Preferences

beta

(Uzwane) #1

Expected behavior

See the sysctl textbox in the Preferences Advanced settings.

Actual behavior

The sysctl textbox is missing in the Preferences Advanced settings.

Information

Docker for Mac: version: mac-v1.12.0-beta16.2
OS X: version 10.11.5 (build: 15F34)
logs: /tmp/20160619-142111.tar.gz
failure: No error was detected
[OK] docker-cli
[OK] app
[OK] menubar
[OK] virtualization
[OK] system
[OK] osxfs
[OK] db
[OK] slirp
[OK] moby-console
[OK] logs
[OK] vmnetd
[OK] env
[OK] moby
[OK] driver.amd64-linux

Steps to reproduce the behavior

  1. Upgrade Docker for Mac to Version rc2-beta16

Docker for Mac Version rc2-beta16 does not have the pinata command line tool and it seems as if some of the pinata settings were moved to the Preferences settings. I want to set some settings in sysctl and the sysctl textbox for providing these settings is missing from the Preferences Advanced settings. Some other posts on the forum shows that it should be there. I did an un-install and clean install of Docker for Mac to Version rc2-beta16, but still no sysctl settings. I specifically need to set fs.file-max = 524288 for an IBM MQ docker container. Am I missing something? Any help will be appreciated.


(Uzwane) #2

Here is the image of the Advanced Settings as provided in the Docker for Mac documentation.

In my installation, I don’t have the sysctl.conf section.
Was this removed with beta 16, or do I need to do something special during the install to get this?


(Uzwane) #3

Updated to beta 17 and still don’t have the sysctl.conf setting in preferences. Anybody know why or if this was dropped?


(Jontilt) #4

having the same issue - any update to this please?


(Jontilt) #5

bypassing the issue for now with:
docker-machine ssh
sudo sysctl -w fs.file-max=524288
exit


(Uzwane) #6

To keep the setting between restarts, I used:

cd ~/Library/Containers/com.docker.docker/Data/database/com.docker.driver.amd64-linux Change etc/sysctl.conf by adding fs.file-max=524288 Issue commands: git add etc/sysctl.conf; git commit -m 'etc/sysctl.conf change';


(Simonvc) #7

+1 this is a show stopper for @getmondo. We also need to run the IBM MQ container that requires many fs.file-max


(David Sheets) #8

fs.file-max has been increased to 512k in Beta 22.