Docker Community Forums

Share and learn in the Docker community.

Docker for Windows really slow

I could not find this issue posted so I will post it .
I’ve just recently installed Docker and it is REALLY REALLY SLOW. When i mean slow, i mean it takes a few minutes to start up and executed any command is also painfully slow. Please see the following log extract to get an ideea:
[17:27:01.392][ApiProxy ][Info ] time=“2020-03-31T17:27:01+03:00” msg=“proxy >> HEAD /_ping\n”
[17:27:01.394][ApiProxy ][Info ] time=“2020-03-31T17:27:01+03:00” msg=“proxy << HEAD /_ping (2.0095ms)\n”
[17:27:01.407][ApiProxy ][Info ] time=“2020-03-31T17:27:01+03:00” msg=“proxy >> GET /v1.40/info\n”
[17:27:01.415][ApiProxy ][Info ] time=“2020-03-31T17:27:01+03:00” msg=“proxy << GET /v1.40/info (8.0225ms)\n”
[17:28:40.521][ApiProxy ][Info ] time=“2020-03-31T17:28:40+03:00” msg=“proxy >> HEAD /_ping\n”
[17:28:40.522][ApiProxy ][Info ] time=“2020-03-31T17:28:40+03:00” msg=“proxy << HEAD /_ping (1.0148ms)\n”
[17:28:40.536][ApiProxy ][Info ] time=“2020-03-31T17:28:40+03:00” msg=“proxy >> GET /v1.40/info\n”
[17:28:40.544][ApiProxy ][Info ] time=“2020-03-31T17:28:40+03:00” msg=“proxy << GET /v1.40/info (7.9757ms)\n”
[17:30:47.929][ApiProxy ][Info ] time=“2020-03-31T17:30:47+03:00” msg=“proxy >> HEAD /_ping\n”
[17:30:47.930][ApiProxy ][Info ] time=“2020-03-31T17:30:47+03:00” msg=“proxy << HEAD /_ping (1.9687ms)\n”
[17:30:47.944][ApiProxy ][Info ] time=“2020-03-31T17:30:47+03:00” msg=“proxy >> GET /v1.40/version\n”
[17:30:47.952][ApiProxy ][Info ] time=“2020-03-31T17:30:47+03:00” msg=“proxy << GET /v1.40/version (8.0301ms)\n”
[17:30:47.959][SegmentApi ][Info ] Usage statistic: Identify
[17:30:47.966][Actions ][Debug ] Start took 00:06:46.2000705
[17:30:47.971][NamedPipeClient ][Info ] Sending app/version()…
[17:30:47.972][NamedPipeClient ][Info ] Received response for app/version
[17:30:47.972][NamedPipeClient ][Info ] Sending filesharing/get-protocol()…
[17:30:47.971][NamedPipeServer ][Info ] app/version()
[17:30:47.971][NamedPipeServer ][Info ] app/version done in 00:00:00.
[17:30:47.972][NamedPipeServer ][Info ] filesharing/get-protocol()
[17:30:47.973][APIRequestLogger ][Info ] [1ff51e4c] GET http://localhost/features
[17:30:47.977][GoBackendProcess ][Info ] time=“2020-03-31T17:30:47+03:00” msg=“external: GET /features 200 “” “””
[17:30:47.980][APIRequestLogger ][Info ] [1ff51e4c] GET http://localhost/features -> 200 OK (took 7ms)
[17:30:48.006][NamedPipeClient ][Info ] Received response for filesharing/get-protocol
[17:30:48.006][NamedPipeServer ][Info ] filesharing/get-protocol done in 00:00:00.0329330.

It took 3 minutes for docker to respond to “docker info”.

Well, in case anyone bothers to read this, the cause of the problem seems to be related to a multitude of possible issues which may or may not be related.
First possible cause is the existance on my machine of a previously configured office VPN. Whenever i connect to the VPN then docker instantly becomes much faster.
Second possible cause is related to the fact that docker adds some entries in the “hosts” file which, i think may not be reached if connected/disconnected from VPN.

What I’ve also done is configured docker to work through WSL1 for Windows 10 with Ubuntu. Now it seems to work great even if i am or am not connected to the work VPN. This is the guide i used for making this work: https://nickjanetakis.com/blog/setting-up-docker-for-windows-and-wsl-to-work-flawlessly