Docker Community Forums

Share and learn in the Docker community.

Docker Hello-World: Getting "getsockopt: connection refused"


(Kendaop) #1

I’m experiencing a seemingly common issue, but none of the proposed resolutions work for me. I’m following the Get Started guide, but I can’t get past Part 1 successfully. docker login as well as docker run hello-world don’t work. I get this:

$ docker run hello-world
Unable to find image 'hello-world:latest' locally
C:\Program Files\Docker\Docker\Resources\bin\docker.exe: Error response from daemon: Get https://registry-1.docker.io/v2/: dial tcp 34.225.121.244:443: getsockopt: connection refused.
See 'C:\Program Files\Docker\Docker\Resources\bin\docker.exe run --help'.

I’ve changed my DNS server to 8.8.8.8, as suggested in the forums (but not in the documentation), and I’m not behind a proxy server. I’ve even tried executing netsh winsock reset and rebooting, to no avail. This is really frustrating, as I’ve been trying to get Docker to work for days. Can anyone help me out?

I’m running Windows 10 Pro, version 10.0.16299. I’ve uploaded a diagnostic: 475C7103-2521-48D7-BBFD-25CB5D8864BF/2018-01-31_10-39-09.

Thanks.


(Kendaop) #2

I finally got it working. The culprit was Kaspersky anti-virus. I had to disable Web, Mail, and IM anti-virus. I’m not sure exactly what this means for the security of my machine, but at least Docker works, and as an added bonus, I am now able to update Java!

Hopefully, this helps someone else out in the future.