Docker Community Forums

Share and learn in the Docker community.

Docker hub credentials on IoT Edge Device

Hi guys,

I finally took some time to start learning about all things related to IoT edge devices and the wonderful world of deploying code to these devices in containers.

The only thing I’m currently stuck on (and this might be so trivial, but I just can’t find it) is how I can pass my credentials to the iot edge daemon running on my ubuntu 18.04 server. I’ve created and published my container to a private repository on docker hub, but when I deploy it to my edge device, I keep getting an error when it tries to pull the image: requested access to the resource is denied, autentication required.

All tutorials I can find use the ACR (Azure Container Registry), but I have my reasons to stick to docker hub.
(e.g. https://docs.microsoft.com/en-us/azure/iot-edge/tutorial-machine-learning-edge-06-custom-modules)

I can share config files, logs, etc, but please tell me what you need in order to help me.

Thanks a lot!

Nic.

Solved the problem myself, for future reference:
in deployment.template.json, make sure you have the correct URL in “registryCredentials”: https://index.docker.io/v1/
I tried many different shapes and forms of this URL, but this one is the only one that works!
Also don’t forget the username and password in the same section.