Docker Community Forums

Share and learn in the Docker community.

Docker image loads without error but docker run can't find it

Hi,
OS: Linux Lite 5.2
Docker version:

Client:
Version: 19.03.8
API version: 1.40
Go version: go1.13.8
Git commit: afacb8b7f0
Built: Fri Dec 18 12:15:19 2020
OS/Arch: linux/amd64
Experimental: false

I loaded a Teradata Jupyter lab docker without errors using the following command:
docker load -i teradatajupyterlabext_2.1.0-ec10132020.tar.gz
Then I tried to check it the image was loaded using

sudo docker ps -a
And get:
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
046087f1a9dd hello-world “/hello” 36 minutes ago Exited (0) 36 minutes ago sad_taussig

It looks like the image is not uploaded, but I didn’t get any error while uploading.

I also tried to run the loaded docker with:

sudo docker run -p 127.0.0.1:8888:8888 -v TD_JL:/home/jovyan/JupyterLabRoot teradatajupyterlabext

And get:

Unable to find image ‘teradatajupyterlabext:latest’ locally
docker: Error response from daemon: pull access denied for teradatajupyterlabext, repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied.

The docker image was downloaded from the Teradata.com site.

I’m new in docker and followed the exact installation steps provided with the docker image.
Has anyone experienced something similar? What steps should I take to get this docker up and running?

Thanks in advance