Docker Community Forums

Share and learn in the Docker community.

Docker install container-selinux hang on centos

docker

(Dsaydon) #1

i have centos 7 (on Xen) and I’m trying to install the latest stable update. first thing that I did is to stop the docker service and remove old versions from the procedure: https://docs.docker.com/engine/installation/linux/docker-ce/centos/

then I have tried to install docker-ce using the command (I have already added the docker repo):

sudo yum install docker-ce
from some reason the installation hang.

command output:

Loaded plugins: fastestmirror, langpacks Loading mirror speeds from cached hostfile * base:#### * epel: ###### * extras: ##### * updates: #### Resolving Dependencies There are unfinished transactions remaining. You might consider running yum-complete-transaction, or “yum-complete-transaction --cleanup-only” and “yum history redo last”, first to finish them. If those don’t work you’ll have to try removing/installing packages by hand (maybe package-cleanup can help). --> Running transaction check —> Package docker-ce.x86_64 0:17.09.0.ce-1.el7.centos will be installed --> Processing Dependency: container-selinux >= 2.9 for package: docker-ce-17.09.0.ce-1.el7.centos.x86_64 --> Running transaction check —> Package container-selinux.noarch 2:2.28-1.git85ce147.el7 will be installed --> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================================================= Package Arch
Version Repository
Size ================================================================================================================================================================================= Installing: docker-ce x86_64
17.09.0.ce-1.el7.centos docker-ce-stable 21 M Installing for dependencies: container-selinux
noarch 2:2.28-1.git85ce147.el7
extras 29 k

Transaction Summary ================================================================================================================================================================================= Install 1 Package (+1 Dependent package)

Total size: 21 M Installed size: 76 M Is this ok [y/d/N]: y Downloading packages: Running transaction check Running transaction test Transaction test succeeded Running transaction Installing : 2:container-selinux-2.28-1.git85ce147.el7.noarch
the installation hang on container-selinux. after stopping (I have waited 1 hour) the yum install process I’m getting the error:

warning: %post(container-selinux-2:2.28-1.git85ce147.el7.noarch) scriptlet failed, signal 2 Non-fatal POSTIN scriptlet failure in rpm package 2:container-selinux-2.28-1.git85ce147.el7.noarch
now here is the strange thing… actually after stopping the process the container-selinux has been installed (not sure if successfully) so after that I was able to install docker-ce without issue but only after interrupt the fist installation that was hang

any idea how to complete the installation without the be hanging?

remarks:
already tried reboot
already tried to install using the command: yum install --setopt=obsoletes=0 docker-ce
the repository extras already enabled
no disk space or performance issue on the server
already tried: yum-complete-transaction --cleanup-only
there is already containers + volumes that their data (under /var/lib/docker/) is still exist on disk